Appending Actions doesn't work & more general Action-related Problems


after searching the internet for hours, I finally found this discussion, which seemed to be matching my problem.

In this discussion, Mr. Joshua Leung said that the problem doesn’t occur in 2.63a, but for me it does - or I made a nooby mistake. But I tried a lot of things and start to lose my motivation, so I would be very very thankful for your help.

My problem(s):

Following the “Game Engine - Simple Character” Tutorial on I am saving my project every half of an hour or so. During two of those “development versions” (18 and 22, the ones attached to this post), I somehow “lost” the walk-cycle action. Trying to append it (from version 18) to v. 22, it works one buggy time (looping the “stand-still” action until i press Arrow-Up. Afterwards it loops the walk-cycle until I release “up”. Then the game breaks down, it doesn’t change back to the “stand still”-action and the walk-cycle can’t be repeated). Furthermore, I am not able see the appended action in the NLA-editor or in the dopesheet (or load it into them). After saving and reopening, the walk-cycle-action is gone again. Also, I played around creating many many actions (mostly copying the existing ones), and somehow after save and reopen, there is ALWAYS only one action left, no matter if appended or created in the current file.

To sum it up:

  • The appended action (walk-cycle) doesn’t “really” work in-game (doesn’t change back to stand-still, and walking can’t be repeated once it stopped)
  • Appended (and created?) actions are lost (except for the last created one) after saving and reopening the file.
  • Appended actions can’t be seen in the NLA-editor or the dopesheet (and there doesn’t seem to be a possibility to load them into there as well?)

I would be very, very happy if you can help me, and I hope I didn’t just make a nooby mistake. If this problem has already been solved, please let me know.

Thanks a lot,

Woody Mues


m_018_with_walk_cycle.blend (580 KB)m_022.blend (620 KB)

Actions to be saved need to have an owner (object) or the “F” option enabled (next to the action name in action editor). Otherwise the action will not be saved to file.

This is a general problem. For whatever reason the “F” option is not enabled as default for a few Blender versions.

Thank you very much! It works :slight_smile:

Solution (just as you wrote):
I just have to load the action into the action editor after appending it - and then activate the “F” option before saving.

PS: To solve the one remaining problem (it doesn’t change back to the “stand still” animation) I had to put both actuators to “loop stop” and change the priority of the “stand-still” actuator to “1”, leaving the priority of the “walk”-actuator at “0”. Is that the right way of doing this? It seems a bit odd (and in the Tutorial I am following, both priorities are left at “0”).