Appending rigify

Hello, to all! I’m in the questionning of : why is there a wrong import of my Rigified mesh models,
at certain places i get only the bones with no gizmos and dummies of my rig.

Like so: i want like right, with dummies, and with append i sometimes lose everything, like left.
Thank you i wanna say it only happens FROM TIME TO TIME! Thanks.

Hi. So, I’m not familiar with Rigify Addon;

But what it looks like to me is that those gizmos, in the case you do not know, are the Bones’ Custom Shapes feature (you can easily access the feature in Pose Mode, with at least 1 Bone of your Armature Selected, go to the Properties Editor > Bone Properties Tab > Viewport Display Panel > Custom Shapes Panel). Those rigs’ gizmos —Custom Shapes— are usually just very simple mesh Objects that the rigger designs; I guess they need to be referenced somehow. For this purpose, I believe the safer thing is to keep them (the original mesh Objects) in the file and in the Scene, but disabling all of their Visibilities, as you can put them in a different Collection for organization. If they are not inside the blend file or not in the Scene, there should still be ways to reference/Append them (but I’m not totally sure about that)… but this means that the original mesh Objects must be somewhere else… and if you simply Append a Rigify Rig that mayhap already is dependent on its own Appending for its Custom Shapes, this might not automatically cascade and you will get the Armature but not the Custom Shapes.

I suspect this is what is happening: before you Append a Rigify Rig, you need to know where the Rigify Rigs’ Custom Shapes (actually, their mesh Objects) are (if they are in the Rigify’s Rig blend file, or maybe on another file), and reference/Append them accordingly (perhaps, even manually, one by one, besides Appending the Rigify Armature itself; but don’t worry: there should be very few of those mesh Objects, because what the Rigger does is reuse a same design/pattern for setting up many different Bones on Custom Shapes in the Armature, by just adjusting different Position/Rotation/Rotation on each of the Bone’s Custom Shapes properties). So, I guess it will depend on how the Rigify Rig is constructed/organized —but maybe you can edit the original Rigify blend file so that it doesn’t create this hypothetic non-cascading Appending issue or something else.

Additionally, if this doesn’t solve anything, it could be that the settings of the Custom Shapes are wrong in some weird way; or there could be Visibility issues as well that might come along with the Append Rigify Rig maybe (not Visibility issues for the original mesh Objects of course, but for the Custom Shapes feature themselves), so, for example, you need to have always Show: Shapes checked < Viewport Display Panel < (Armature) Object Data Properties Tab < Properties Editor; for your Armature.

Hi there. Ensure that your Rig and WGT collection are in one collection and then append that collection. Even still, there is a bug which means you may have to save, close your file and then reopen it for the Rig layers to appear in the Item tab, but that should solve your issue.

1 Like