Appending


(kattkieru) #1

What’s the deal with appending?

I’ve tried loading objects/meshes/anything from other .blends, but on all three systems I’ve tried (Mac OS X 10.2/Blender 2.25, WinXP/Blender 2.25, Redhat Linux 7.3/Blender 2.25) nothing I do seems to work. I somehow imported two objects once, and now I can’t do the same again.

What’s the secret? Can someone let me in on it? :-?


(BgDM) #2

As far as I have always done it, just Shift+F1 to open the append file manager. Find you blend file and go to the mesh directory. Then find the mesh you want and press the select button. Works for me every time.

BgDM


(mthoenes) #3

Yup, works fine. The trick is you do not append the entire file, You go in and append the objects or meshes or textures or lights,

I generally append from the objects folder. I get the mesh and the materials along with it. (It is helpful if you have named your objects in the file you are appending from.!!!)

It you have a parenting situation in your “from” file, You will need to import the parent and child objects to keep the parenting relationship.

Good Luck.


(jrt) #4

Hi,

 I was thinking of doing a post on this subject myself . I have had similar problems. When 

I was using 2.23 I could append anything in the blend files with the yellow boxes by them. But recently the append function seems to be very picky. Sometimes when I click on a file all I get is an empty page. I’m not sure if it’s since loading 2.25 or after I started using XP. There doesn’t seem to be any set pattern to it though, most of the older blend files are OK but some of the resent ones are too. I’ve tried going back to 2.23 again but that seems to have caught the same disease. There appears to be entire folders
where nothing will append and others where just about everything is fine. I’ve tried moving files around and saving to different folders but once Blender puts the stamp of disapproval on them nothing seems to change it’s mind.

Frustrated, jrt.


(kattkieru) #5

Glad I’m not the only one. I was thinking I was crazy. :o

I’m having a better time under the Linux version. I can import stuff about a quarter of the time. It’s totally random however – I can import a part from a .blend, but if I try to import the same object again it doesn’t always happen. I dunno.

It’d be nice to have a command line .blend merger until this gets fixed. It’d also be nice to have a real tree view inside .blends, so that you can more easily select a bunch of different data types, you know?


(rwenzlaff) #6

What I want is an “Import Children, too?” prompt.

One thing to try though is importing the Object, not the Mesh.