Apply Constraints (Remove, have Object stay in place)

I have an Empty with a “Copy Transforms” Constraint.

I need to then (a) free it from the constraint but also (b) have it maintain the same Loc/Rot/Scale.

Removing a Parent/Child like this is obviously very simple with just Alt + P > Clear and Keep Transformation. But I cannot figure out how to remove a Constraint and have an Empty maintain the precise rotation.

Thanks in advance.

Well Location should be easy… Pick your Empty… Shift_S > Cursor to Selection… > Delete Empty > Pick your Object > Shift_S > Selection to cursor… Rotation… hummm … I will have to do some figuring on that one…

Yeah, I gotcha with the Location. But I need Rotation, specifically. (Again, the same way that you can maintain the position when removing a Parent.)

Thank you.

Note the Rotation of the Empty before you delete it… then simply enter those values into your object once you have it in the right location… Ctrl+C Ctrl+V to cut and paste the values even…

Well, the Object’s own values are separate from the Object it’s slaved to.

For instance, I have it Constrained to an Armature Bone. And if I copy the Empty’s location, then remove the Constraint, and then paste its location…it just jumps way over to its own original position, which is where those figures are from. So its LocRotScale aren’t altered as its moving along the Constraint.

Is this what you meant?

I think that’s awesome. Makes me feel layered. Like some sort of epic lasagna
http://www.primeaffiliate.com/track/images/11.tod.gif

This was solved by mfoxdogg at the BlenderQA chat.

It’s very simple to remove a Constraint but have the Object maintain its position:

Space > Bake Action

A menu then pops up, which essentially gives you the option of turning it into a full animation (for instance, if you had a head tracking to a moving Object, you could remove the “Track To” Constraint and it would automatically register it as Keyframes, I believe).

In my case, I just wanted some lights to maintain their position, so I just set the “Keyframes” from 1 to 1, and it just locked them into their position. You’ll figure it out. The main thing is Spacebar > Bake Action > the menu.

4 Likes

this still works in Blender 2.93 :slight_smile: thanks!