Applying 2d image to coffee cup - unwrapped it, but image is repeating. Why?

Rather new to this but have unwrapped a coffee cup and no matter what type of unwrap I use the image repeats itself horizontally and vertically around the cup.

How can I turn this off so I can exactly position the image where I want it without it repeating?

Thanks.

check ‘clipping’

‘Clilpping’… where’s that?

in the texture settings, under “image mapping” (not “mapping” thats a different panel) change the dropdown menu from repeat to clip.

apologies for the ambiguous reply. :RocknRoll:

Am I missing something here? I don’t see an ‘image mapping’ panel. Attached is what I’m seeing.


That’s because you’re using Cycles render and not Blender (internal) render and didn’t mention it.
You also have compositing node tree enabled without compositing nodes. Cycles uses node materials so switch to that tree, and put node connections: texture coordinate: UV -> Mapping -> image texture -> whichever shader you have -> material output. Then enable min and max in mapping node.

oh. cycles. that explains it.

give me a moment to figure it out

ok well this video explains everything, and is only about 5 mins long, very simple solution

oh. JA12 beat me to it. cool well the video explains what JA12 just said.

Ok, believe I did what you said, JA12 - thank you - but don’t see anything changing in the view port when I adjust the number in the mapping panel. I see things change in the preview panel but it doesn’t update in the view panel so it’s hard to see what is doing what.


Rendering shows what is really going on with the texture. Draw a render border around the cup (ctrl+B, ctrl+alt+B to clear) and switch viewport to rendered shading mode (shift+Z).

Edit: mapping and material settings are correct

Ok, I’ve got the image to line up just about perfectly however, it’s repeating across an area of the cup (around the handle) where I don’t even have it mapped. I need that area and the handle to be blank or white. Why is the image bleeding to the handle area and why is the handle blue?


dont worry about that. just set up a new material for the handle. i presume you just want a plain ceramic cup texture for that part of the cup? any way press ctrl i to invert the current selection. (the selection in your image. you maybe changed it by now, but thats the image i’m working with.)
ok invert selection and choose your new material from the material slot. in edit mode press assign which is a button just under the texture preview panel. now you have you image mapped to your uvs and a diffuse texture applied to the handle area. that should be all.

oh just FYI you’ll often get texture bleed across your faces when you have a subsurf modifier on the model. you can fix it with control loops or just dont worry if it is not making the model look wrong