Applying AO to my textures

So when i press the Ambient occlusion button on my View-port it shows me what my model would look like with the AO; but shown on my current textures for the model. But when i export my model my textures don’t contain the AO which i would very much like to see as it adds a lot more detail.

For example this is what my model looks like with the AO setting on. How do i implement this into my texture for use when i export it to say sketchfab or Unity3D?

In the Render / Bake panel you can bake AO to a texture which you can mix with your current texture

I tried baking to a new image and i get this problem. Any tips?