Applying bevel modifier inceases number of loop cuts


as a blender beginner: A simple cube with 2 loop cuts in each dimension being beveled with the bevel modifier. When applying the bevel modifier: I understand the additional faces at the beveled edges, but why is the number of faces in the midst of the body increased as well when applying the bevel modifier? Is there a way to keep the oiginal loop cuts when applying the bevel modifier?


Limit your bevel to Angle

If you don’t define a Limit Method for bevel modifier, each edge of mesh is beveled.

Thank you, Limit:None is bevelling each edge, Limit: Angle only “sharp enough edges”, I guess then less than 90 degree.


Don’t guess, look at the options :unamused: When you choose the ‘Angle’ method, you get to set the angle. By default it’s 30 degrees, i.e. any edge sharper than that will be beveled.