applying textures

I loaded an image texture, and I can’t figure out how to apply it. I have the plane with with light and camera all good but it just render black. When I right click the plane it even brings up the texture in the box, but it won’t show on the renders.

Did you Add a Material, Add a Texture, Select “Image”, then “Load Image”, and above the “Load Image” button it now shows the path to the directory that image was loaded from?


Yes to all of your questions. It shows up like it is going to be there, but the render is just black.

Press 0 on the Numpad to make sure the camera is looking at the plane and select your lamp and change it to a Spotlight or an Arealight so that you can rotate the dotted line to point it exactly at the plane.


It is set on the default lamp that is there when you start blender and the camera is pointing at the plane.

Then you have to look at Materials (Alpha slider, ZInvert) or lamps (only shadow, layer) or render settings. If you want to you can send me the file ([email protected]).


Trust me.

Try this tutorial and see if your questions are answered.

I sent you the .blend file. No, the tutorial didn’t help.

You’re not getting a black render, you can see the plane and the world color behind it. You didn’t pack the texture (File >> Pack Data) and I don’t have it on my box so obviously it doesn’t show up here. But when I load one of my textures I can see it fine, so maybe your Ground_013.jpg is corrupt (check it in a paint prog). Or just try another texture as a test.

Your lamp is also set to 30 units (up that to 100) and energy 1 (either up that too or add more lamps so you can see the whole scene). You have the texture set to “Repeat” which will repeat it across the plane like a checkerboard.


No matter what I change the light settings to the plane is unaffected and stays completely black.

Edit: So I opened a new file and did the same thing I think I see what the problem is. If I size the plane to small it inverts and show on the wrong side.

Edit2: It still won’t work on that particular file I think will just start with the new one.

Edit3: Does it matter my lamp was in a different layer but I had both layer visible?

to Edit3: only matters if your lamp is set to “Layer”