apt trouble

yesturday i tried to install mplayer on Debian. it failed for some reason i cant remember, and now when i try to use synaptic pakage manager, i get this error:

E: Internal error opening cache (1). Please report.

.

any ideas?

i know this isnt much of an error, but its all i could find.

thanks!

Have you tried making sure there is nothing stuck in the background locking the cache? You could either open up a command prompt and check with ps, or rebooting would work. I would then run an ‘apt-get update’ just to refresh the cache. Mplayer was failing yesterday because of a dependency on mplayer-skin which didn’t exist and it wasn’t switching to mplayer-skin-blue, however as of today it seems to be doing fine now and detecting mplayer-skin-blue as the dependency.