Aray with deformation object

Hi Guys,

I have a small problem (take a look at the picture). I want to create an Array with a certain object. But whatever I try, my object always deforms when using an oval Nurbscircle. I want no deformation of my object. It should stay like tthe sample object in the middle of the oval. I hope it is only one setting I have to change.

Who can help.

Thanks in advance,

Paul :smiley:

Try duplifaces or dupliframes

Hi JA12,

Thanks for your reply, but it doesn’t seem to work when using a circle or nurbscircle.
I am not that experienced with Blender. I think I need a decent tutorial.


Both methods used here. The goal is to get a flattened cube around a nurbs circle without distorting the shape (if I understood correctly)


  • Instead of arraying the cube and using curve deform to get it around, use a plane (1)
  • then parent the cube to the plane and enable duplifaces for the plane (object properties -> duplication: faces) (2)
  • that puts a cube on each plane face. The planes are distorted but the cubes are not


  • Curve has path animation frames set to 9 in curve properties (object data properties)
  • Cube is parented to the curve
  • Cube has its duplication set to frames and speed option is unchecked
  • That puts the cube on each frame on the curve (3). If you check ‘follow’ option on curve properties -> path animation, cubes will orientate along the curve

duplifaces_dupliframes_ja12.blend (94.9 KB)

… or, since you already have planes go around the path - set Duplication = Faces on Obj tab for the plane, create object you want to duplicate on the Origin point of the path and parent Object to plane by selecting Object, Shift select plane and Crtrl-P, Parent.

Yea they look like planes but it’s actually a cube. It’s selected, object name is Cube and its dimensions tell it’s not a plane.

Something like this?


Array.blend (443 KB)

@JA12: That would make my Zoo look funny! Easy to fix though - delete 4 verts…

Hi Guys,

Thank you all. This solved my problem.



Great tip! Thanks!

I just have to mention that it was hard to find the Dupilcation Panel in the Properties -> Object,
because i was always trying out the menue(viewport) -> Object -> Make Dupli-Face

After i saw another tutorial i could understand!


Hi Eppo,

Looks perfect, but how do you hide the sample object in the middle without hiding the ones in the Circle?


Never mind. It’s gone when rendering.


Hmmm, another Problem is now, that i still can see the planes.
How i can hide them, without hidding my duplicated objects in the same time?


This is something different. Neither BI nor Cycles render objects which have Duplication set. Check your objects one more time.

Here is my blendfile.
May someone please take a look at it?


Ok, i saw your exsample and there is the same issue.
I want to see just my duplicated objects and later make them to one mesh, without the planes.


003_ringblume_v005.blend (724 KB)

You are not going to see the planes and the source for the duplicates when you render.

If you want make it into a mesh first apply the modifiers top down nd then use ‘Object menu/Apply/make duplicates real’ but you will no longer have the flexibility of positioning using the curve.

You can’t show just the dupliobjects and hide their parent. For rendering it doesn’t matter, only the dupliobjects show up.

If you want to shape the objects and have an array with duplicates, first make the array and then turn the array to duplicates afterwards. Don’t really need full array, just enough to see the chain working. That way you don’t have parent object distracting while you work. Could then use small planes for duplication so they won’t fill so much of the view.

Or, if you want to edit the shapes and the duplication is distracting, disable duplication or isolate the original objects using local viewmode. Making duplicates real can be done with ctrl+shift+A (or ctrl+A to show the apply menu).