Archipack 2.2 for blender 2.8 RELEASE

I get this error when I try to activate it:
error

Hi,
did you “Remove” old one ?

Steps to update

  1. disable old one
  2. press “Remove”
  3. restart Blender
  4. setup new one and set the material library path

I did. I even downloaded the latest build and it didn’t help.

Could you share full error message ?
as i’m unable to repro here.

It seems that link didn´t work with my download manager and after trying to download without it in another browser, I get a message that token is expired, and I need to request a new link

edit: so it worked to just request again through the link you provided :slight_smile:

I get the exact same error message as captainkirk when trying to activate

Hi, narrowed down the issue.
The link is only working once, erasing file on server as soon as it is downloded.
So request a new link using the form.
The link should open a browser and start download, maybe copy and use it on another browser without download manager.
If it still fails for you i may add an alternative method (send addon through e-mail but this require the mail server to handle files with more than 2Mo)

Here´s a screncap of the error message in console

Thanx,
fixed now on server, but you may still get cached file from your browser.
Will try to prevent any cache on browser for this file.

So if we redownload it should be good?

Yes, shoud be good now.
Also tweeked download manager so browser should not cache the file.

Sorry for trouble, and thank you guys for reporting !

1 Like

confirmed working. Thanks! :slight_smile:

I can also confirm it’s working now. Thanks for dealing with it so quickly.

How to export gltf with the default materials?
They seem to disappear or the color is set to white.

Hi TripleAAA,
I don’t know if gltf exporter does support multi-materials / cycles shaders, you should ask gltf exporter author.

You can check glTF related issues or create one here:

It supports multi-materials but I believe they need to be connected directly to principled BSDF. Complex shaders might not works and need to be baked.

It took me 2 days to figure out you could disable glass and make windows light portals in 2 clicks. This has solved a major reflection problem for me. I also wanted to ask if there is a way to move a door back even with the outside of a door jam or frame. Doors where I live do not sit flush with the outside of the casing. Otherwise how do you mount your hinge to the door jam. Right now I have a front door with the door flush with the outside of the casing. Maybe I have not looked hard enough to find these settings.Thanks for your great addon.

In Archipack is there a way to turn off gloss in the glass to prevent reflections? I was selecting the separate window panels and trying it that way but it would not work. If you select the window unit itself does that work? I am rendering and have to wait until it is done before I try. Thanks

Hi,

For the door, maybe enlarge panel thickness a bit may help in achieving such result.

For the glass, take a look at Realistic Glass in Eevee

By default archipack re-use materials, wich means that if you modify “glass” material all objects using that material will be affected by this change.

The door jam is the same width as your wall.or just a touch wider. The front edge of the door should be flush with the jam. Then you have a casing which sits on the jam and the wall and sticks out another 2 to 2.4 cm. So the door is backset from the front edge of the casing 2-2.4 cm. My door is flush with the front edge of the casing. Therefore the hinge is part way on the side of the casing and part way on the jam. The hinge should be 100 percent on the door jam for strength.