Are keyframes always sampled when exporting to FBX?

Hi, I have been exporting some simple model animations to FBX format, and I noticed that a LOT more keyframes are saved into the FBX file than I have created in Blender. It appears that the keyframes have been sampled for all frames between the first and last keyframe. Is this because Blender is trying to preserve some existing F-curve data in the export? How would I disable that? Thanks for any help!

Reducing the precision value in the export settings to give fewer keyframes

I’ve never been able to get the exact keyframes I made in Blender to be the only frames exported when I do an FBX export. Reducing the precision value is the only way I know of to reduce the amount. I think that’s just how the FBX exporter works.