Arifacts, how do I remove them?

Look at this:
http://img21.imageshack.us/img21/5776/artifactsb.png
I have tried to remove doubles but they don’t dissapear. Is there some easy way to remove them? Also another question, I have had the symmetry check box checked while sculpting. But the two sides of the face still aren’t identical. What is the easiest way to at this point achieve symmetry in the sculpture. Delete half the model and use the mirror modifier, but that isn’t perfect, but as good as it can get?

Was this sculpt made or started with a Blender version from before 2.66a ?
There was some problem with Dyntopo generating loose edges and vertices in some condition.

This shouldn’t happen with 2.66a Dyntopo.
If this sculpt was entirely made with 2.66a Dyntopo, you should report it to the bug tracker

Now to remove them, 1st go to Object Mode and see if they’re a separate object from the sculpt, if you can select them without the whole sculpt.
If yes, just delete them there.

If they’re still part of the sculpt, try the Michalis solution :

editmode
select none
[ctrl]+[alt]+[shift]+[M](select non manifolds)
[ctrl]+[-]
[x] delete vertices

For the symmetrisation, go into sculpt mode, enable Dyntopo and click on the “Symmetrise” button (be sure the “Direction” is correctly set depending on the symmetry direction you want)

Omg thank you, all of these tricks works great! :slight_smile: