Armature actions not deforming meshes in BGE


I’m fighting with this issue for a long time, I keep having trouble with a simple thing.

  1. I’ve got a character mesh, and an armature.
  2. The mesh is parented to the armature using “Deform using blah blah weights” - it created a Armature modifier in the mesh object’s stack.
  3. I’ve got my “Walk” action created and logic needed to run it ( Action actuator with frames set in the Armature’s logic bricks connected to player’s main object that receives keyboard events.
  4. I’ve removed the modifier and instead changed the relationship type between the mesh object and armature from “Object” to “Armature”.
  5. The animation plays fine in the viewport.
  6. My mesh jumps into “rest pose” right after I run the game and never changes.
  7. I tried adding a Armature actuator doing “Run Armature” fed with Always Positive Pulses - nothign changes.

What am I doing wrong? Is this a bug?

Below you can see the “rest pose” with arms wide spread:

And here’s how it looks like in the viewport, the character is in pose named “Stand” (arms down):

You can download the project file from Google Drive:

The armature modifier must be always the first modifier in the stack.

After reading your notice, I tried the following:

  1. Changed the meshe’s relation to armature from “Armature” to “Object”
  2. Manually added an Armature Modifier to the mesh object’s stack and pointed the armature.

It works.

I gotta repeat it a few times to get sure that I can do this. Don’t know why such a simple thing gets me so much trouble.

Thank you, HG1!

please change the link to corrected version.