Armature and pose mode problem!

hello everyone.
Ok i am doing a project for school and the intro was to have one of my characters to stand and witness a ball rall up to his feet.The i was planning to make him pick it up.And some other stuff.Ok i started with an icosphere and set it up to go to the feet of my character.But when i move my characters feet and set location rot scale then go to the next frame.The armature rotates and faces down.Here is a screenshot:

Thanks in advance.

Have you “connected” the character to the Armature ?

To do so you have to either :

a) Select the character, then SH-select the Armature and press CTR-P, and choose Armature, then the approriate vertex option


b) Add an Armature modiifer to the character. The default of Envelopes/Vertex Groups will probably have the armature able to move the character somewhat, but proably not like you expect or want. You’ll either have to tweak the envelopes or the vertex groups.

If none of this makes any sense to you, then see the “Intro to Character Animation” tutorial (links in my signature) and skip ahead to the rigging / Weight painting section.

If you have “connected” your mesh - Armature together, then check that :
The delay deform button in the Editing Buttons / Editing Options is not on

If you still can’t get it work, post the .blend file somewhere ( is what I use).


here is the .blend file if anyone wishes to correct this problem:


Select your armature in OBJECT mode and press alt-G, alt-R to clear the location and rotation. You ‘ll see the armature rotate to "lying on it’s back’. Now rotate the armature to fit your character and then press CTR-A (apply rotation). It should work properly now.

It looks like you created the armature from the top view, but modeled your character from the front view.

When working with armatures, be consistent, create the armature / character in the same views. Also armatures can get messed up if you edit in one orientation, rotate them in OBJECT mode, then rotate them again in POSE mode.

Also althoug your IK arms will work, it’s a strange setup that might cause you problems later. You don’t need the “double set” of forearm bones. If you were trying to setup for both IK/FK , you can just turn off the IK with the influence slider in the constraints.

Also it’s a good idea to have a separate IK target bone for your arms, parented to either nothing or a master root bone, that everything else is parented to. Especially if you’re going to try animating a character picking something up, or especially if it’s supposed to be something heavy. You want the arms and hands to be “left behind”, while the body starts to move, which won’t happen if your IK bones are children of the arms like in your present setup (hands children of arms … and hands are the IK).

I’d also suggest turning off your subsurf’s in interactive view (click the middle button in the subsurf), it will make everything react much quicker.

To make a character pick up a ball, assign a location constratint to the ball with one of the armature bones (hand) the target. You can key the constratint to be 0 until the character is supposed to pick up the ball, then key it at 1. Change the IPO curve to a CONSTANT interpolation to make it switch instantly. Even better than using a hand bone, I’d add a couple of bones near each hand parented to the hands but unconnected, call them something like HandHold.R/L, then use them for the copy Location constratints for the ball. The advantage is that you can move the HandHold bones around and even keyframe to adjust the “pickup action” more precisely.


I think you might have created your 1st bone in top view and rotated 90degrees in front/side view and forgot to ctrtl-A (apply scale/rotation) .
Just alt-R (clear rotation) and your rig will lay parallel to the top view . Go to sideview (numpad3) R key 90 press ENTER then ctrtl-A (apply scale/rotation) .That should fix your problem . Hopefully all your vertex groups aren’t going to get messed up ;{

You mght also want to make use of Shift+S (the snap settings) and press N to have the Transform Properties window to see what you’re doing .

Mike_s:thanks a bunch man!!!:wink: :smiley:

Vertex Pusher:thank you too man!:smiley:

oh and one more thing.How do i get sculpt mode to work.I have downloaded and unpacked the zip already but have no idea where to start???:confused:

You’d be best to start a new thread when you have a different question. There’ll be many times when the people who read and help with your armature question might not be able to help with a different issue like sculpt.

I can say that a lot of people are finding sculpt mode doesn’t work in some cvs. The first thing you need is a hi-res mesh. Practice with a default UV Sphere. Go into Sculpt Mode (from the mode menu) and try Grab (adjust the sliders). This works for most people so if you have some luck with this try the other features.

Good luck.

hank you andy d.
My question was actually how do i get sculpt mode in blender.


You need to download a “CVS” build (pre 2.43 release)


I don’t know if this is the official way to do it but you have to move the patch (in its .exe form) to the dir. where the main Blender.exe is located and click on the sculpt mode-.exe in that dir . . Blender will start up with the patch functioning . Though if you exit Blender and start up with your usual shortcuts you will get your 2.42a version without the patch .
This works with Windows anyway .
Does anyone know how to make the patch(s) permanent (without building from code) ? I downloaded the new Particle Pactch and can’t seem to load the .bend files Jenka(?i think that’s the author) made for demonstration … I guess I should post a question …

The “patches” you refer to are standalone .exe’s just like the “official” blender releases. They typically are distributed without the extra support dll’s / python scripts, but dropping them into the main blender directory is fine, unless they have updated dll’s or other files distributed with them. In that case I would create a new directory and copy any misising dll’s/other files / python scripts from the 2.42a distribution over.

As far as “shortcuts” go, just make a new one to any “patched” blender exe, that way you’ll be able to run whatever blender version you want.

I haven’t tried the particle version, so I don’t know what the problem could be … it would be best to post in that thread for any problems with it.


Thanks mike . But I was trying to help out trak wrecka use the patches . tells you to put the patch in your blender directory . They apparently depend on some dlls located there . I’m a noob to Blender ; ) not to computing (or following clear directions) .
Hopefully I don’t come across as being cross . You seem to be quite thoughtful in helping others (like your response to trak wrecka up there - very helpful) .
I guess I’m usually more prone to just lurk then post - but no one seemed to be helping in this thread until mike you and I posted nearly the same time .
Anywho I guess I like to help when I can as well …

Thank you Mike (!) What you said in your thread should be more visible in the official documentations or you know … more out there. It was very useful (!)