Armature causes shapekeys to mess up object textures in-game

I’m having a problem that I can’t find a solution to, if I add shape keys to my object the textures mess up when I start the game engine. The thing is that if I delete the armature attached to the model, the problem goes away. I also imported a very similar armature from another file in, and the problem doesn’t happen when I attach it to the model with the shape keys. So its obviously the armature causing the problem, but I have no idea what exactly is wrong with it. Has anybody had this problem, does anybody know how to fix it?

Again, deleting the armature, or even just the vertex weights on the object associated with the armature gets rid of the issue.

EDIT: I want to fix the current armature with the problem, and not make a new one.


I’ve never had this problem, no, though it sounds interesting. It has something to do with the armature itself, huh? Is there any modifiers applied on the mesh?

Just the armature modifier. The reason why I think its the armature is because I imported an armature from a newer model I did and the problem doesn’t occur when I attach it. I built both armatures following the same way. The only difference is that I have been working with this model through many different blender versions, since the start of working on Faith 2 with 2.49 I believe. The armature was re-built from the ground up though, fresh. The model has just been reworked, but it can’t be the model because like I said it doesn’t mess up if I import another armature that is basically the same just a couple bone name difference.

I have been thinking maybe it’s something to do with vertex groups, or whatever they affect? I don’t know much about them so I can’t really look into it.

EDIT:Also removing materials from the object doesn’t do anything, so it’s not that either.

I would be willing to send you the file privately if you would like to check it out, any help would be great.

After all this time, I finally solved this issue! It was simple too, The problem was being caused by setting the armature deform to BGE optimized, setting it back to Blender fixes the shapekey issue in the game engine. I’m not sure if this is a bug or simply a drawback of having an armatures deform optimized for BGE, but I figured I’d give an update just incase anybody else runs into this problem.

Heres an image of the setting:

this issue still exists in 2.68a and can be solved the same way (armature deform = Blender or no shape keys)
bug tracker :