Armature disappeared?

Hello,

I just rendered my animation and now there’s a couple of things I want to fix. But the problem is that the armature has disappeared?? It should be there since the character it was attached to is moving and it’s showing in the nla editor and outliner but it just isnt anywhere. I tried alt+h already but no. I clicked the first layer button under the display options in the armature edit mode but it did not appear, what on earth is going on?

Is the mesh and the armature on different object layers? In object mode, in the 3d window, there are a series of layer buttons to the right of the 3d manuliptor controls.

You could also go into the outliner window and select the armature there to try to find it. Objects can be made invisible there, could it have gotten turned off there somehow?

Hope this helps,
Randy

It should be visible, at least the eye-button is activated in the outliner. When I click the armature in the outliner and then Edit mode, I can see and edit it. It just doesnt show in the Object or Pose mode.

I think the problem is that the bones are invisible, I just did something in the outliner and saw that they had a closed eye pic but then I lost that view that and now I cant find it any more -_-

Ok, problem solved now :slight_smile: Thanks for the help!

Can you post a .blend? Those were the only two ideas I had…

Never mind then…

How did you fixed it? I have the same issue here.

I had the same thing happen to me and I tried everything finally I went to the outline and clicked the armature that wasn’t visible and then went to the left side of the 3D window and went to the rigify animation tools and clicked on each bullet in the drop down while watching the 3d screen. as I did one of the clicks brought the armature back up and made it viewable again.
Hope this helps someone.

I have painted myself into a corner.

I have duplicates of the same character and rig. Did some animation tweaks yesterday which required making single user versions of the NLA tracks (that had me guessing for a while) but today when I opened Blender I only seem to have one rig.

Two characters with different animation, but I can’t access one of them any more and the Armature appears to be missing from the outliner completely - no longer a parent in the chain of mesh and bones in View Layer mode.

The only reference to the Armature is as the object reference under the Armature modifier, but that’s all I can find. Probably doesn’t help that I experimented with installing the Animation Layers addon briefly, but I can’t seem to find my way back.

PS. This is a Rigify rig. One of the defaults (Shark).