Armature Error

Can you take a look at my weight painting please?

I think I did it right, and the upper part works just the way I want it to, but the legs/hips go crazy. Can you help?

hmmm…legs look good. left and right shins kick ok. the bone isnt lined up with the mesh, so he goes a little pigeon=toed, or maybe that was from me playing around. In answer to your question, your weight paint looks good to me!

Your weight painting / vertex groups for the leg.l, leg2_r.001, hip_l ,hip_r are probably not where you want them . And you probably don’t even want the “leg2_r.001” group.

Two tools to use -

  1. In weight painting mode, press SH-LMB over the mesh and it will display the name(s) of the vertex groups assigned. When you see an area that has more than one vertex group assigned, you can either change the weight to 0 and re-paint that area after selecting the bone you don’t want to influcnce that area

  2. Use the Vertex Groups panel in the Editing (F9) buttons with the mesh in EDIT mode. Press “a” to select/deselect all vertices, then choose a vertex group and press the SELECT button to see which verrtices are included in the group. When you see some verts that you don’t want included in a group, you can use the b(ox) or bb(ox) select tools while holding the ALT-key to deselect the verts that you want to KEEP in the group, leaving only the ones you DON’T want in the group selected. (Press ESC or RMB to exit the b/bb(ox) select mode)

Then press the REMOVE button in the Vertex Groups panel to remove those vertices…

Or you can just use the SELECT button to show all verts in a group, then REMOVE them all, and go back and select the ones you do want and press the Assign button to put them into that group.

For a further step, you can have verts assigned to multiple vertex groups (bones), but with different weights associated with the groups. E.g. the left thigh might have
the top verts of the leg included both in the leg_l and hip_l vert groups, with the hip_l vert group having a weight of .5 (green(ish)), and leg_l group having a weight of 1 (red). But start with having all weight groups at 1.0 (red) and assigned to distinct vert groups before refining them into multiple vert groups.


Thanks for the compliment, RogerWickes, and thank you for the in depth post, Mike_S. I’ll try out those new shortcuts.

However, my problem lies in my posing of the legs. When I do it, they get over- deformed, and they look rather bad. :slight_smile: I think this may be because of not enough faces, or to many faces, but I’m not sure.

The main cause is because the leg vertices are assigned to both the hip and leg bones. If you remove the verts from the hip_l/r vert group(s), you’ll see a big improvement.

You might want to subivide the “spine1” area of the mesh so there are additional verts between the top of the leg and the middle of the body.

Also adding a subsurf modifier to the mesh will make it look much smoother.

I also (just) discovered that when you use the SH-LMB in weight paint mode, you can then LMB on one of the names in the vertex group list popup that appears, and that vertex group will be selected. You can then switch to EDIT mode right from weight paint mode and use the Vertex Groups buttons. Using both the Weight paint tools and the Vertex Groups buttons is the fastest way to tweak the settings.

Another handy thing is to select the mesh, and in the Edit buttons / Modifier panel, for the Armature modifer, turn on the ‘Enable modifier during edit mode’ and ‘Apply modifier to editing cage during Editmode’ buttons (the third button and the fourth “seperated” button in the Modifier panel for the particular modifier.


Thanks for all of these shortcuts. I was thinking that there must be another way to switch from Weight Paint to Pose Mode.

Also, I need to keep it this low poly, because i plan to use it for a game. But I’ll try adjusting the hip_l and hip_r vert groups.