Armature not sticking to object

When I add bones to my character, in pose mode the character does not move with the bones.

I have tried:
Adding 3 bones
In object mode, clicked on object then the bones
ctrl + P (with automatic weights)
In just doesn’t want to work.

Any help?

You need to supply a link yo your .blend file if you want any help. Without that you are just making it 10x more difficult for anyone to be able to help you !!

Get rid of all the crap from your file before supplying it, just supply only the important stuff

untitlxed5.blend (776 KB) Here is the .blend file

OK I have taken a look:

You have no weights assigned to the bones for the leg object - all vertex groups show no vertices when selected. This is why the mesh does not move when you move the bones.

You have applied an IK constraint to the bottom leg bone, having not set it up correctly before applying it. I never apply these constraints as you can’t then modify them. This becomes apparent when you try to move the bottom bone, it goes orange in colour and the other bones cannot be rotated - that is the clue!

So you need to start again with the armature, delete the one you have and remove all links to it in the mesh. The first thing to add is a root bone, on the floor between the feet, to which other major bones and IK targets should be parented. The you add your spine, shoulders, hips, and leg bones - and name them properly! Then you parent the mesh to the armature with automatic weights. To do this you select the mesh, SHIFT Select the armature then key CTRL+P and choose “Automatic Weights”. If you are adding IK constraints, do not apply them, they cannot be altered and they may well mess up the rest of the bone chain.

You should do some internet searching for proper bone naming conventions.

Also you have two armature modifiers for the mesh, you should only have one.

The dark un-natural colouring to your mesh is because you do not have your faces normalised, so most of them are inside out. To correct this go to edit mode, select all faces, then key CTRL+N - that will turn them the right way round.

If you want to redo a parenting, you should remove the armature modifier, delete all vertex groups, remove the parent object and then start again with the parenting operation.

Search out and study Nathan Vegdahl’s “Humane Rigging” tutorials - they are very good and will show you everything you need to know about character rigging.

The body is all made of Tris - three sided faces, it should be Quads - four sided faces for blender, also there are no where near enough vertices to animate the mesh, you must work in Quads and have sufficient vertices to get a good deformation. Do not over do this as you can then use a Sub-Division modifier to get a really smooth shape. Set the Sub-Div to 2 for view and render to start with and check the Optimal Display checkbox. Then click the “Smooth” button in your 3D view right side menu.

It would be a good idea for you to look at some good basic modelling tutorials before you try to rig this thing. Good modelling is essential before you can rig and animate.

These two tuts are very good, they will take you around one hour to complete - they will save you many days of frustration:

https://wiki.blender.org/index.php/Doc:2.6/Tutorials/Your_First_Animation/1.A_static_Gingerbread_Man

https://wiki.blender.org/index.php/Doc:2.6/Tutorials/Your_First_Animation/2.Animation

Then of course add the root bone (between the feet) to the armature and parent the upper arm and leg bones to it, as this is VERY good practice, it is not done in the tut, that’s my only complaint with it! To move, rotate or scale the entire character you then simply move/rotate/scale the root bone and everything else follows.

Cheers, Clock.

PS Welcome to BA - we are here to help…

EDIT:

This quad (the only one I found on my quick search) is definitely NOT GOOD as it has a reflex angle between two edges, this is a no no:


Stick to obtuse angles at most.

I forgot to say; this is not the way to do toes:


This will cause you all sorts of problems in the animation, you should create islands (I command in Edit Mode) the move and extrude out the resultant inner face. This will all be in the tutorials out there…

Here’s a quick example:


With a Sub-division modifier to smooth the whole thing out. This was made from a cube, which I subdivided, scaled in Z only, then created two island by selecting both pairs of end faces (one pair at a time) and keyed I - then I moved these new “island” faces along Y axis, then extruded them twice and scaled the edge loops. Modelling toes that disappear inside the foot (as you did) is not good practice and will result in poor deformation when rigging and animating.

Cheers, Clock.

Finally, for now - the nearer your quads are to being square, the better they will be for you - yours in the image at the top are far too long and narrow.

EDIT:

You could even remove the inner edge loop as I have done here if you do not want it to make some more deformations:


Thanks for the reply Clockmender!
Although this is a rough draft, thanks for demonstrating how to make the feet.
I won’t have much time today to work on it, but I’ll let you know when I get it working or have any more questions.

Here’s mine and yours rendered with a simple Cycles material:




Cheers, Clock. :slight_smile:

Just followed the tutorials, and got my first animation and it works!
Now it’s time to start over on my mouse.

Thanks clockmender!