armature problem (vertices not 'seen'?)

I have an extremely simple rig, but I just can’t get it to work right!

here’s the problem:
http://extrapuur.nl/blender/armatureproblem.jpg

as you can see, to the right of the middle, a few vertices are not being moved by the bones… I have all the vertices in the mesh in a vertex group and all these vertex groups are attached to the armature (by the auto name match functionality). I checked to see if I missed vertices by selecting everying (A), and then deselecting every vertexgroup from that selection. But alas, no left-over vertices. Is this a bug, or am I missing something?

here is the blend

Did you WeightPainted it already?

No, I worked with vertex-groups instead (I find that easier & more precise) Of course, it’s not more precise when it comes to actual weighting, but this should be pretty straight-forward

Those verts are just UnAssigned to either Vertex Group. You can select the Vertex Group and, with all verts unselected, press Select on each and you’ll see those will still not be selected.

%<

%|

Then check your Bone names (especially 3 and 8)

%<

Thank you, I don’t know how that happened, but it did…

anyway, it bends like it should now!