Armature re-targeting problems on character model

So I’m working on this Chibi model and using Mixamo for animations but when I link the walk animation to the base pose it animates, but the arms are crossed over as if they are linked to the opposite bones but it has the base pose from Mixamo that comes with the skin/mesh and the walk animation that is just the skeleton with animation data and it re-targets perfectly in Maya, Unreal and Unity. Blender is the only program that can’t figure it out even though I’m following the exact steps to get it all working. It’s very weird, I even just tried switching to .DEA and it does the same thing except it binds the legs side ways. I have no idea at this point any help would be greatly appreciated. I’ve run through this process on 2 different models and I’m getting the exact same result using different walk animations as well. As you can see the hands are crossed over in both models, 2 different models, 2 different rigs, 2 different walk animations, same result. Thanks in advance

You haven’t said what steps you used. Try it this way. If it doesn’t work, get a little specific on your exact steps. Version of Blender. How you exported, etc. Otherwise, we can’t figure out your exact steps.:frowning:

I apologize for the vagueness since I could replicate the problem constantly I thought it might be a common problem.

So the version I’m using is v2.79 and those steps you linked are the exact ones I followed but something I realized last night is that when I tick “!EXPERIMENTAL! Apply Transform” It gives me this error (in picture below) and won’t import the FBX.

The exports are straight from Mixamo just like in the guide to retargeting so at this point I’m assuming the Experimental apply transform tick box is the problem here and hopefully if I can get that working it will fix the weird cross over arms problem I’m getting on every model.

I’ve made an interesting discovery. That error is only happening on the actual base FBX with the skinning data and I tried importing one of the other animations and re-targeting it to another animation and it works perfectly. So I just need to understand what that error actually means and I can fix the base FBX and it should work.