Armature + sculpt : is this normal?

Hi,

I’d like to use multires and sculpt simply to fix skinning problems when changing pose, not even for shape animations.

Sometimes it works, but here it only works until I move a bone again and then I get this… was it to be expected or should I submit a bug?

Thanks!

I’m not sure what you mean when you say 'not even shape animations"
You’re making a new shape key for the new sculpt right?

No, just sculpting directly, modifying permanently the mesh.

I’ve tried shapes, but in 2.53 they’re simply not recorded when in sculpt mode.

Are you using envelopes at all in your armature modifier? Did you parent the mesh to the armature using bone heat?

I can’t really think of much else that would cause that kind of problem if your mesh doesn’t have any shape keys.

Yes, I used bone heat. No envelopes. The result is vertex groups skinning.

Does that make you think of anything?

In summary:

  • attach mesh to bones with bone-heat
  • Add multires
  • Subdivide
  • Pose armature
  • Sculpt to adjust skinning problems
    until now everything works
  • change pose : boom!

Thanks.

To make it short, yes that is normal. It’s called crazy space, the vertices are transformed in their mix of bone spaces. There is a script called anisculpt that lets you model shapes and apply them without crazy space. Maybe you can bake the shape afterwards.

“crazy space” eh?

I tried to reproduce the problem with a simpler model without success.

Is there a condition for it happen, like vertices attached to more than one bone? Is it possible to force a model to have only one bone attached to each vertex?

Thanks a lot.

Jonathan

I don’t know what’s wrong with the rig but the anisculpt script gives even worse results!

Anyways, I guess I’ll have to find a new workflow.

Ok. The script works without Multires. I guess I can live without it if I subdivide the original mesh enough for my purpose.

Now this is just my opinion and sometimes ppl are very negative to my opinions, but I think it’s your workflow. You attach a mesh to an armature with bone-heat, you add Multires…modifier…I assume? Then you subdivide the mesh? So my thoughts are, if you’ve created new geometry… has it been bound to bones with weight paint? Vertex groups?

Randy

I meant that I subdivided from within the Multires modifier. I assume the vertices generated by multires inherit properties (like weight) from the original vertices.