Armature track-to constraint, texture doesn't move along.

Hi there!

Im working on a character and Im using armatures that are automaticly pointed at an empty to target the eyes.
Everything went fine till I upgraded to blender 2.35a: When the bones follow the empty, the eyes move along but textures stay at the initial position.
I never had this problem before so might it be somekind of bug in 2.35?

I tried isolated the problem as you can see in these images below:

The initial setup, one cube with the eye texture from BlenderChar at one side.
http://edukitty.org/~barry/3d/projects/exploits/initial.jpg

How it renders in 2.34:
http://edukitty.org/~barry/3d/projects/exploits/blender234.jpg

How 2.35 makes a mess of it:
http://edukitty.org/~barry/3d/projects/exploits/blender235.jpg

What the setup looks like:
http://edukitty.org/~barry/3d/projects/exploits/overview.jpg

The .blend file for those who are interested:
http://edukitty.org/~barry/3d/projects/exploits/trackto_texturebug.blend

I’m using a track-to contraint assigned to the bone in question with the pose-mode.

I already posted for this bug at Blender BugTraker, fixed by Ton (in a new release to came, 235b). This happen also with model animated by NLA.

Env

Eey, thank you. I should have checked it before this post :slight_smile:

For those who are interested: it is already released but without any notice (yet). Check:
http://download.blender.org/release/Blender2.35/

Edit: and you know what: it ISN’T fixed :frowning: still the same

It was fixed yesterday, those builds are just too old to have it (except perhaps the OS X one).

Martin