Armatures not being applied?

Hi guys,

I’be got a bit of a wierd problem:

I’ve been able to do armature based animation before, but for some reason it’s not working for me all of a sudden. I’m hoping if I explain my method someone can point out where I’m going wrong.

I’ve got a simple mesh of a goldfish I want to animate. Originally I modelled it using subsurfing, but I’ve converted it to a plain old mesh now that the modelling stage is finished. I’ve been through the mesh creating vertex groups, and writing their names and positions down on paper. I’m sure the vertices are attached to the groups, because I can select / deselect them using the select/deselect buttons in the group creation area in the edit button window pane.

I then created a series of armatures close to the vertex groups. Once all the armatures were placed, I named the bones to be the same as the vertex groups. Finally, I parented the fish mesh to the armature, and chose “Use Armature” from the dialog box that appeared. Then selected “Name Groups” from the second dialog box.

The problem arises when I enter pose mode with the armature selected. I can move bones, but none of the mesh moves.

I have rechecked the vertex groups, vertex group names, and bone names - everything seems to be fine. I’ve looked through the blender knowledge base, but didn’t find anything useful. I’ve looked though my blender 2.3 guide, but it seems I’m doing everything correctly.

If I reload the blender file from my previous save (immeadiately before I parented the mesh to the armature), I can parent the mesh to the armature and choose “use closest bones”. This successfully attaches the vertices to the bones, but the attachments are all not very sensible (as so often happens when using this shortcut).

I’m totally lost now… Could someone please assist me with this?

The blender file that does not have the mesh parented to the armature can be found here:

The .blend file saved after the mesh has been parented can be found here:

I hope someone out there can tell me what I’ve done wrong!

Thanks in advance guys… :o

Well, i opened your file and parented the mesh to the armature, and guess what, it worked.

So yeah, just select the mesh, then the armature, press ctrl+p, then choose “armature”, and then choose “don’t create groups”.

Your next step is to parent all the bones together. :wink:

edit: to unparent two objects, select them both and pres alt+p.


I’ve just done that again, and it still doesn’t work. May I ask what version of blender you are using?

It may be a bug or mis-install in my blender app…

Thanks for the help!

I’m using blender 2.34. Should i send you your blend file with the working armature?

edit: Here’s the file with the armature working

I think it’s because you’re choosing “Name Groups”. That creates new vertex groups with the names of the bones, and that might override the ones you have. Choose “Don’t Create Groups”.

As a side note, I think you might be going about the whole thing backwards. Model, then make bones, then assign vertex groups to them, it’ll probably be easier than the way you did it, and work better. It might be good to keep the subsurfed mesh, too, as it’ll deform smoother, unless it’s too low poly to use as many bones as you want to.

yep, that’s the order I did it…

I got it going now, thanks a lot!