armatures not moving


I have managed to do a walkcycle with moving the armatures in pose mode, and the body parts following them.
but now, I wanted to make the character follow a path. and I realized, that as soon as I move the body, the armatures stay where they are.

can anyone tell me how to fix this?


have you tried animating the armature object? You could use a bone within the armature that moves the whole rig too so that everything is kept within pose mode.

hello again

sorry for not having written back for so long.

so, i tried diffrent things, and i realized, that I had to take the bones out
of the pose mode, and into object mode, and then I could parent them to the mesh.

but now, i followed a tutorial, where I made a more complex rig.
and there, in the end, i parented the mesh to the rig.

so now i’m stuck with the same problem, because if i want to parent the rig to the mesh,
it gives me a loop in parents error.

when i animate the rig, the mesh moves. but if I move the mesh, the rig stays where it was.

and sorry, I don’t quite understand what you’re suggesting…

Make the Armature the parent of the mesh, not the other way ‘round. Then you can transform the Armature as an Object (not in Pose mode) and the entire mesh will follow along, as well as moving to the bones’ animations.

Note that when you make the Armature the parent of the mesh using CTRL+P, you’ll have different options for the parenting. Which you choose will depend on whether or not you’ve already created vertex groups for animating with the bones.

You can skip those options by simply entering the Armature name in the Mesh’s Transform Properties Parent: field, but this can sometimes cause offsets in the mesh’s location, so beware, you may have to correct for that.

Whether you animate the Armature directly as an Object, or make it a child of another object like an Empty, or use constraints on it, pretty much depends on the kind of animation you’re planning.

hmn… i think i haven’t been enough clearly on this

ok, so i made my rig the parent of the mesh. when i move the rig, he mesh follows very nicely and satisfactorily.

but when I move the mesh, the rig stays where it was.

I know, this isn’t a problem if you do a walkcycle or anything similar.

but lately i wanted to do a path animation, and I followed a certain tutorial. there it said, i had to clear the values of the location and rotation, and then set the mesh on the beginning of the path. and then the rig stayed where it was.

but gosh, i just realized, is it so simple?

if I want to do what I mentioned above, I just hae to do those things to the rig, and not the mesh? is the solution to my problem that simple?

Yes, it seems so.

ok, i’ll try it that way. i hope i won’t have any more problems with that.

thank you very much for the help and the time you took, i appreciate it very much!