Arnold for Blender: 0.2.0 Alpha Available

I’m excited to announce that I’ve been working on an Arnold renderer add-on for my studio called BtoA, and it’s close to an alpha release that’s viable for testing.

For real this time, guys.

Although the official alpha won’t be ready for another week or two, you can still download the code and try it out today. I try to keep the master branch stable enough that you can install it and start poking around, even though it still needs a lot of work. If you come across any bugs, check to see if it’s listed in the issue tracker - if it’s not, open a new issue so I can take a look! Please don’t use the issue tracker for general support, though. If you have a general question, feel free to either DM me or respond here and I’m happy to help as best I can.

Now, I’m going to address the elephant in the room once, and then I’d rather we leave it there. I know a lot of us were disappointed when the guys behind the previous Arnold for Blender add-on suddenly announced they were no longer releasing it last month. There were a lot of promises made and not kept, but I’m not interested in dragging them through the mud - I’d rather focus on creating a great add-on we can all use and enjoy. BtoA is written completely from the ground up, but I was able to salvage some code from what was publicly available in the old project’s repo. It’s hard to tell exactly who wrote what without sitting down and going through the repository commit-by-commit, so I’ve listed everyone that had a hand in the old project in a contributors file. I don’t agree with their methods or decisions, but they put a lot of hard work into it and deserve the credit for that.

Finally, this is my promise to you: all of the code you see on the BtoA repo will always be exactly the same as the code we run at my studio. Development will happen in the open, mistakes and all, because I truly believe it will be a better product when we all get a chance to contribute (code, testing, or otherwise).

Although it’s not feature-complete, we’re going to start testing it in production as soon as this month and I hope you guys can do the same. So go for it! Download the master branch, install it, test it out. And let me know where it breaks!

Special thanks to @AlexeyAdamitsky and @NoahMuiruri54, who have been testing out the awfully buggy pre-alpha builds for me, and @B.Y.O.B for his insight on a custom node implementation. I really appreciate you guys taking the time to talk with me and test things out.


Installation instructions:


And, a note on current usage quirks: when creating a new shader, you have to create the shader from the Properties panel first. You cannot create a material from the Arnold Shader Editor! Because of the way the node tree is linked to material, this will create a node tree without a material to link it to and Arnold won’t see it.

1 Like

The 0.1.0 Alpha release is here!

We’ve been working hard over the past few weeks to put a bow on a minimally-viable Arnold for Blender build that can be used in production, and now it’s finally here. Feel free to download and start rendering!

For those who want to get more involved with BtoA - in any way - we have a Discord server set up for easy communication - there’s an invite link in the repo README. We’d love to see you there!


Keep going,I used to use Arnold in Maya. I like Arnold’s rendering window, which can save historical rendering results for comparison

Great news!
This is awesome. Thank you for the plugin. I’ll test it and if I could help at some point, pls tell me!

You’re always welcome to get involved. If you want to chat more about it feel free to either DM me here or on the Discord server!


Just installed the latest version of Arnold SDK (, and it didn’t work on both Blender version 2.83 LTS and 2.91.2. It gives me a transparent rendering image. Then, installed version of the Arnold SDK and it worked properly on both Blender versions. I’ll try with versions between them to see what happens.

What I’m missing is the thin film on the Standard Surface shader. Idk if the reason for its lack is something related to the old project, but it’s something to see. I know it’s a very early stage of the plugin, but I’m pointing my first impressions. Another thing is some strange negative values for Transmission, SSS, and Coat, that don’t make sense.

I’ll do a lot of tests with different scenes and start to see (and learn) deeply about this project. Your studio made a great thing, bringing light to this project. Thank you very much. Let’s keep this thing alive.

Thanks for bringing this up. Can you capture the output from Blender’s console window and either send it to me in a DM or open an issue on the issue tracker? Arnold gives us a pretty comprehensive log, so it’ll likely tell us where it’s failing here.

I believe thin film has been implemented - there’s very little code from the old project and I remember working on this at one point. I’ll take a closer look this weekend though. You shouldn’t be able to set negative values for things like transmission, SSS, and coat though…can you give me a little more info on what you’re seeing?

Thanks for bringing these up! Let’s work through them and get them into the issue tracker so they can get fixed.

I encounter this after setting the environment and following the instructions about the installation.
any fixes.

There are a small handful of people that are experiencing this right now. Honestly, we’re not really sure why it’s happening at the moment. I can’t reproduce it, and as far as I know my testers haven’t been able to either. It’s still considered an open issue.

The dev branch is pretty stable at the moment - you’re welcome to download that and try. I’d also recommend completely disabling and removing the add-on, shut down Blender, then open a blank scene and try to install it there.

If anyone else in the community has recommendations let us know - as far as I can tell this is more on the Blender side than the add-on side at the moment but I’ve been wrong before. :slight_smile:

1 Like


How did I miss this one?? Awesome to see Arnold arrive for Blender, thanks a lot!! :heart_eyes:

Got both the Arnold SDK and the beta addon installed & activated with the notes.
One note, I -had- to set the ARNOLD_ROOT variable too, or the addon would throw errors on activation.
Too bad it’s for 6.x and up, as I still have a license for Arnold 5.x :wink:

I quickly tried to render something, but was getting a green background with the newest SDK. So it’s hard to do any shading tests. Also a F12 render was just a empty render.
After reading through this thread, I stepped back a couple of versions but this is happening for me on as well.

Any tips where I go wrong here? Does this work without a license?



same here… non actived arnold sdk (it work in trial mode like dcc plugin version? or is this the empty render problem’s?)


It’s the green BG & empty render, and are probably connected. The ‘regular’ Arnold plugins would render but with a watermark, not sure about the SDK version tbh…

edit: the renderview is not implemented yet. And after a restart I can render with F12. :slight_smile:

1 Like

Hey guys! Material preview and viewport render haven’t been fully implemented yet, hence the green render.

Arnold will render with a watermark if you don’t have an active license - a transparent render usually means something went wrong. Can you look in the console window for error messages? Arnold is pretty good about telling us where it went wrong.

Also, if you’re rendering with the default cube, it might help to remove the default material and add a new one. BtoA can’t read cycles materials yet, so if it’s not a material created specifically for Arnold it will give us grief.

I’m experiencing the same issue on all versions of Blender I have. It’s possible I’m not savvy enough to follow all instructions fully but not sure what to do at this point.

@blankblinkblank, if you shoot me a DM with whatever error you’re facing, I’d be happy to help you figure it out. :slight_smile:

Just put the ARNOLD_ROOT variable and point to the SDK folder.

Hi Wayland, I tried some of the other versions of the SDK and I have issues with versions and It was the version of the driver_display_callback.dll. I compiled the driver to the version of the 6.2 SDK and it resolves the problem with the error on the Blender console. But keeps aborting…

Log from the console without new driver compiled:

Log from the console after compiling the driver

Just tried to edit the config.ocio to remove the XYZ data and ta-da! It works.
Below is the code from the edited ocio file from blender:

Thanks for taking the time to look into it! There’s an open issue about BtoA not working with Arnold 6.2, so this will definitely help fix it.

Editing Blender’s default OCIO config is a no-go as a long-term solution, but it may help us pinpoint a way to resolve it. I’ll add it to the open issue so we can get it solved for good.

The issue is the name of the CIE XYZ transform named XYZ as it collided with the role named lowercase xyz. Without it though, everything will fall to pieces that requires the CIE XYZ transform.

Change the transform name to BT-709-XYZ and set the role for XYZ to that name should do the trick.