Array modifier along curves using object offset...

Hello,

I don’t know if I’m just missing something fairly basic, but I’m trying to tesselate a model around a central point as demonstrated here in the Blender manual. I have an empty set up and parented to the model to be tesselated using the array modifier, but there must be some part of the process I’m just not getting; it starts to rotate like I’d like, then inexplicably scales down into oblivion. Can somebody either point me to a thorough step-by-step explanation, or give me a few pointers as to what I might be doing wrong? I’d pretty much like to mimic what’s shown in the image “Object offset example”. I’d appreciate any advice anybody can give me.

Nobody has any ideas, eh?

Have I asked a question that’s some kind of touchy subject with people, or is it difficult enough that there aren’t any people that know?

No, we’re playing a game called, “How frustrated can we make the new guy?” :smiley:

Seriously, I don’t know. I’ve never tried those functions before just now. Could you post a screen shot showing the settings you’re using for the array modifier, settings for any other modifiers you’re using, and a description of exactly what steps you took to get there? Or perhaps post a link to your .blend file? I’d be happy to take a look at it and see if I can figure it out, I’m just not sure exactly how to duplicate your problem is from your original description.

Is this what you want?

http://img.photobucket.com/albums/v639/Ryu_Kaiser/Array.jpg

What I did:

  1. Start off with the default scene.

  2. Delete the left and right faces off the cube from top view. (optional)

  3. Add an emtpy (space > add > empty) in top view

  4. Selected the cube and added an Array modifier.

  5. Set the count of the array modifier (for the cube) to 25.

  6. Activate object offset in the array modifier.

  7. Typed in the name of my empty with is “Empty” by default.

  8. I then select my empty and rotate it anti-clockwise a bit to the left until I get that ring of objects.

  9. You’re seeing spheres in my model because I subsurfed the cube to level 2.

Good luck,

Wolf

Wolf: Yeah, that’s what I’m talking about. I have it set up the way you’re talking about, too, and it’s not working. Like I mentioned, the copies begin to rotate, but then scale down at the same time. Maybe it’s because the little pink object centers aren’t exactly lined up? I’ve heard that can lead to unpredictable results but I’m not sure. Before I activate the object offset, my copies are in a completely straight line one in front of the other; is yours the same? Thanks for the help, by the way.

Minor update:

I followed your instructions, this time using “Constant Offset” rather than “Relative Offset,” and arrived at some slight more predictable results. Rather than rotating around a center as yours do, mine more twist uncontrollably around their central point, even heading out into Z-axis territory when I haven’t specified (or seen anyplace to specify) that movement. Any ideas?

Here’s a screen shot tutorial I made for you TheRiddler.

Step 1:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step1.jpg

Step 2:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step2.jpg

Step 3:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step3.jpg

Step 4:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step4.jpg

Step 5:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step5.jpg

Step 6:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step6.jpg

Step 7:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/step7.jpg

Anything you don’t understand in the screen dumps, give me a shout.

To follow this tutorial, just start up Blender on default and start from there.

Important: make sure you don’t move your empty object, unless you want to create something like the on in the blender wiki tutorial.

Like these effect:

http://img.photobucket.com/albums/v639/Ryu_Kaiser/example.jpg

I scaled the empty object (in my case “ArrayController”) and maybe rotated it anti-clockwise a bit more.

I really appreciate the help, man; you went above and beyond the call of duty, there. I think I’ve pretty much got it figured out, now. Unlike your example there, my usage has the first and last piece connected. I’ve ticked the little “First Last” button, but in the reality of the mesh the first and last piece are a little off square; that is, they’re not lined up for some reason, and even the most subtle adjustment of the Empty twists and deforms the circle the meshes form, a difficulty compounded by the sheer number of vertices. Aside from that little foible that I’m working on, your advice has worked pretty well. Thanks again.

how do you make the arrays real?

What do you mean by real?

Like when you enter edit mode of the object/mesh it has all the vertices for that spiral look?

If that’s what you’re after, then once you have created the spiral like the one in my screen dump above:

  1. Select the cube in the middle.

  2. Enter edit mode and find the array modifier that is making the ring of cube.

  3. Look for the “Apply” button and click on it.

Your mesh should have all the vertices for which the array had created.