Array Modifier Problem

Just been trying to create an X sided object using the array modifier, similar to the example
in the Essential Blender book, ie using an empty to create rotated versions of the mesh.
But it just takes the object I want duplicated to form the X sides and seems to create random copies of it wherever it feels like.
All I can think it is doing is applying all the scales/rotations used to create the object in the first place to the further copies that are created with the Array moifier.
It doesn’t seem to say much about anything I could have done wrong in the book or in the documentation…

Could you post a screenshot, or preferably the blend file itself? I’m having trouble guessing at what went wrong without knowing exactly what you did.

I’ve tried to attach the screen.
I just recreated it as simply as I could.
Added a mesh cube, moved it a couple of units up the y axis and multiplied it’s scale by 2
in the y direction.
Then added the empty at 0,0,0. Then applied the modifier ‘array’ to the cube.
Instead of creating a circle of cubes from the original cube it did what you can see
from the attached file (if I’ve attached it properly).
Hope you can make it out properly. (I Used the Num Pad 2 keys etc to slightly offset the viewing angle to make it a little clearer).
If I don’t modify the shape of the cube that is originally added (when I do Add->Mesh->Cube) then the array modifier does what I expect and fans out the copies of the cube in a circle centered on the empty.

Edited to say: Obviously I rotated the empty.

Attachments


Alright, I think I figured this one out… :slight_smile:

The array modifier is comparing the scale, rotation and position of the original object and the empty, and modifying duplicates based on that difference. When you scaled the original, it’s now trying to apply that difference in scale to all of the dupes.

To fix it, select your cube and hit Ctrl-A to apply scale and rotation. Applying the scale causes them both to be scaled to 1, removing the slightly unpredictable results.

In the future, you can avoid this problem altogether if you scale your cube in Edit Mode (tab) instead, which operates directly on the object’s vertices.

Lemme know if this did the trick.

Yeah, that fixed it. Thanks.
Hmmm…Not had this problem before.
Like you say, even though I applied transformations before the Array modification, it
takes modifications done at any time to apply to the array modifier. Can see the logic in it. Maybe.