Array not working with Alpha Tex!!

I have created a “Plane Object” then added an array modifier to it to duplicate the plane object. This worked!

So now I added an alpha texture to the plane so it looks like it’s cut out but when I turned the “Array Modifier” back on the array was not working as the duplicate planes don’t show up. What am I doing wrong?

pg

Does the “Array Modifier” in 2.5 not work with textures? All I did was select “Alpha” in the Textures and then add an image as my alpha map, I then tried to use the array modifier but it wouldn’t work.

When I deleted the texture the “Array modifier” worked.

.Blend File
http://www.********.org/blend/3426

pg

Anyone!

pg

Does anyone know if you can use textures with the “Array” modifier? Thanks.

pg

I am not able to download your file, but I’ve just tried to replicate your problem and it worked - created a plane, assigned an array modifier, assigned a material with z-transparency and alpha texture. And it showed up correctly on all instances of the object. Maybe you have the texture mapped wrong so it’s not visible on the duplicated objects.

Yeah, paste all is blocked. For some reason, it is in the dirty word list.

Duffator,

Thanks for trying this. I have the image mapped correctly and I used z-transparency and alpha too but still isn’t applying to the duplicates. I’m wondering if I have missed a setting somewhere. Did you have to create the array modifier first, then apply the texture. I created the texture on a single plane first, then applied the array modifier.

Would it be possible to post the me the file you created somewhere?

pg

I tried it both ways and it worked every time. Here’s my .blend http://dl.dropbox.com/u/8279144/array_test.blend

Atom, yeah, I’m not sure what’s up with paste-all. hopefully it’s fixed soon. :slight_smile:

Thanks so much Duffator, I will give this a try.

pg

Ok, I was able to duplicate the problem. Add a plane object to your file and set it at: Z:-0.001

What it is is that I need a “plane object” for a floor just below the array planes and when I add this it causes the flowers background to go black. I have tried to adjust the settings to fix this but I am at a loss as to how to fix this. I set the plane object (floor) at Z: -0.001 and the black appears. Any ideas how to fix this?

pg

http://img442.imageshack.us/img442/1013/flowersl.jpg

Hello,

Looks like the “Premultiply” box in “texture” panel woudn’t be checked. Could this be it?

Hmm, you can get rid of the artifacts around flower by eneabling premultiply and fields. As for the black shadow i am clueless… i tough that it is shadow caused by AO, but disabling A,O disabling the cast shadow on the flower material and eneablin the “floor” material to recieve transparent didn’t solved it.

@Duffator. You are correct. AO can not see through raytraced textures, so it needs to be disabled in these kinds of scenes. Another approach is to simply trace the outline of the flower using a curve, extrude then convert to mesh, then you can project the flower on to the extruded curve (which is in the shape of the flower) and still use it in an array.

One thing to remember about transparent shadows is that you have to enable transparent shadow on the receiving floor object as well.

Attachments


Ok, so i tried to make little compositing with nodes - separting the flowers and the floor into different layers and combine them using alpha over, but i couldnt get rid of the square artifact around the flower, it still was rendered into the floor layer, i am sure that it has simplier solution, but my knowledge of nodes is very limited so what i did was to make a new scene,<i> </i>move the flowers into it so they wont affect the floor layer and combine them into compositor.

http://dl.dropbox.com/u/8279144/array_test2.blend

Thanks Atom, but unfortunately, the image I am using is too detailed to trace with a curve so that is not an option for me. Is the black happening only because of the AO?

Question: Do you have to unwarp the plane to use the array with an image? I tried this without unwrapping the plane and I couldn’t get the image to tile properly. It would be so helpful if I could use this without unwrapping as I’ve got a lot of planes to work with. :slight_smile:

pg

@paintguy: IMHO your image is not too difficult to trace (It’s like 40 points or so). Just make the outline of the flower, then add the image map as the texture for the outlined object.In the time it takes to looks for an alternate solution you could have the work done and be enjoying a working scene.

I just traced a sunflower, myself, not too long ago in After Effects. It was about the same quality as yours. There is actually satisfaction in doing the tracing. The sunflower is pretty simple. Just add a curve circle to the scene and sub divie it a few times. Then make the sunflower a background image. Then move the points in the circle to match the background image. After you are done. extrude the circle slightly to give it some depth. Convert the curve to a mesh so the array modifier can be used. Then assign the original image as the texture.

Thanks Atom, but the flower was not my image but Duffator’s. :slight_smile: Anyways I figured it out. I just deselected “Traceleable” in the materials and the black disappeared. Only then you don’t get any shadows at all but I didn’t need shadows anyways for this project.

Sure wish you could just use a plane object and an image with an “Array Modifier” without having to unwrap the plane first. I did unwrap the plane but it wuld be so helpful of you could just use the plane with the (Materials > “Mapping”) set to “Generated” or “object” instead of UV so you wouldn’t have to unwrap. :slight_smile:

Thanks

pg