Array overlap and lighting

(Craig Jones) #1

I noticed while testing out 2.45 on XP that the array overlap areas rendered as black artifacts with certain lights, but not on others. If I used spot, area, or lamp, I get dark areas. I never noticed before, so I did the same in 2.44 as well when I checked the same file. Maybe this has been mentioned before, but I just came onto it now. I was going to try one of those complicated but simple overlay video effects with output, but got sidetracked trying to figure this out.
Thanks ahead of time for any input - I don’t think it’s a bug, but just behavior of the lighting maybe.

Attachments


0 Likes

(Inmare) #2

That behaviour always occurs if you have faces at the exactly same level. E.g. duplicate the default cube and render; same result.

Your relative offset when using the array modificator is not 1.000, right? Oh, or did you use an empty for the curve? I find it much easier to use an array modificator for the duplication and a curve modificator for the path; the array modificator even has the nice “Fit to curve length” option.

0 Likes

(Craig Jones) #3

Yes, I used an empty so the effect would be extreme - like the original instructional tutorial that was on Blendernation when the array modifier first came out.

0 Likes

(Inmare) #4

I found the tentacle example in the current manual most useful, showing the combination of curve, subsurf, array modifier and caps; with correct merging the effect you noticed cannot occur.

0 Likes

(Meta-Androcto) #5

you can turn off the artifacts by turning off raytracing.
it only occurs with raytracing on.
m.a

0 Likes

(Craig Jones) #6

That makes sense, I guess, since I didn’t notice until I used a ray traced spot and an area light… I usually use buffer shadow spots and grouped lamps :slight_smile: I’ll go back to my usual, then. Thanks , Meta!

0 Likes