articfacts in Env Mapping


I was just looking into the old Env Mapping to fake reflections for some products.

I ran into the problem that the moment I use OSA you see white lines around the individual reflection images.

I was searching for problems here already but did not find anything. Any help?

I do not remember having this problem in the past - or I must have forgotten something.


just recently someone else clicked Zinvert and it solved it. I know i updated the wiki with that info. his was “changing the render order”. I know at first we susptected the old alpha premul halo thing, but this is different.

sorry for asking but what do you mean with z invert?

since it is not a plane I am not using an empty in case that is what you mean


Z invert in the materials buttons will invert that particular materials depth buffer during render.

ah mh when i click z invert than i see the inside of the object

look at the attached image, the problem still exists.

here is also a blend file. silly that i dot figure out whats wrong


That’s weird. I’ve just rendered your blend file and didn’t get any artifacts. I rendered it on 2.43 (I’ve got the latest SVN on Ubuntu too, but I happen to be using Windows at the moment and haven’t got round to updating).