Artifacts in-between textured planes

Hi,
I am seeing small lines in between textured planes. Looking more closely, the lines are made of small dots.
Attached are images, one is a zoom of the other.
This is an artifact as there are no dots/lines there. Is there any way to eliminate them?

Thanks,
Ofer

Attachments



That looks like Aliasing. Try choosing a higher Anti-Aliasing sample ratio, like 11 or 14.

Another cause may be overlapping, but unjoined verticies. Going into Edit Mode, select everything, pressing W, and then choosing Remove Doubles should fix that.

[edit]Oh wait, the zoom is viewport, not render?

Blender’s Viewport anti-aliasing ratios are in User Preferences > System, under Window Draw Method. (try Multisample: 16)

Often you’ll see jaggies while working in the viewport, but once you render they should go away.

With bilinear texture filtering every pixel gets interpolated with neighboring pixels in the texture, except on the edges, where pixels get interpolated with pixels on the opposite side of the texture by default. What you are seeing is pixels that are interpolated with the sky color (the opposite side of the texture). There are a few ways to fix this but the easiest way is probably to move your uvs away from the edges a little bit in the uv editor, assuming you are using uv coordinates.
Another way is to change the way blender samples edges pixels on textures by going to the texture panel -> image mapping -> extension and setting it to clip or extend.