Artificats appearing on a cylinder mesh

Hello everyone, nice to meet you all!

I am new here, so this is my first post. Thank you for your understanding!

I made a simple model with a cylinder (no modifiers or complex modelling), but strange artifacts keep appearing when I move the viewport scren around. Could someone help me, please?

I am a new user in the forum, so I can’t post de GIF I made to show the problem. I will try to explain it:

- When I start moving the viewport screen, the faces of the mesh starts flickering creating, what I think it is, artifacts. I have tried Shade Smooth, Subdivision Surface, Flipping Normals and to delete Internal Faces, however, nothing worked.

PS: I am new in Blender as well.

Hi :slight_smile:

Maybe there are two cylinders at the same position. Overlapping faces could cause the flickering.

In edit mode, select a face, press Ctrl+L to select all connected faces. If you move these, you should be able to see if there are other faces at the same position.

1 Like

Hey there @Helge, thanks for answering!

Unfortunately, it didn’t work.

I still can’t upload the GIF :frowning:, but I will try to explain better.

- If I’m close to the mesh, it work perfectly fine. However, as I increase the distance (just a little) of the view the flickering starts.
- The object I’m talking about is supossed to be small compared to the main body of the entire work, but the effect it produces (the flickering) is not intended and very noticiable.

Welcome to the community, @DonValentino11! You can post the image of your issue here ( and share the link here for us to take a look at.

You don’t have to do much more to get to the trust level required to copy and paste images straight into your posts:

Get to trust level 1 by…

  • Entering at least 5 topics
  • Reading at least 30 posts
  • Spend a total of 10 minutes reading posts

So just reading or looking at a couple more topics (what most people would call threads)

Hello everyone, thank you all for the hints!

Since I can upload things now, here is the GIF representing the problem. I hope it makes things easier.

Hello everyone, I hope all of you are doing ok! :+1:

I discovered what the problem was and fixed it! :slight_smile:

Here is the solution and the link of the page where I found it:

- The problem was because the Clip Start was too small, so increasing it a little resolves the flickering problem.
- The Clip Start option can be found in the View menu of the properties panel.
- You can access the properties panel by pressing N

Link to the solution:

I thank you for your collaboration!

1 Like

Nice. I’m glad you found a solution. :slight_smile: