as if it could get any worse

okay boys and girls…hate to keep bugging you…:rolleyes:

thanks to your wonderful help in my last thread…i now am proficiently UV mapping a sharp looking biplane for a game i’m making…now…when i am in object mode…everything looks great…just like i want it too…perfect dimensions and everything…however…once i hit the P button…it goes wacko…everything gets skewed out of size and some pieces dont line up like they do in object mode…

any ideas what to do to fix it? Thanks!


just as an FYI…im having the same problem even without the textures on the plane…its still goofs in Game mode

Hello UncleJas
Did you maybe accidentally add size IPO keys?

post some pics, see what we can do…

Object Mode:

Game Mode:

if you can telll…seems to be out of proportion…and nothing lines up with the wheels below…

hopefully these help…


hmm wtf, i see what your problem is now, hmm cant think of a cause yet…

select each object and click ctrl+a and also make sure there are no ipo’s on them

Try selecting everything and using object->scale to size and aspect ratio, or alt-v.

sweet its fine now…i tried everything you guys said and it works now…so not sure which one it was :-p

thanks though


hey i figured it out…it had to do with i had some of the things parented to the fuselage so i only would have to manipulate that in the game…thats what deems to distort it…:-…don’t know what to do to fix that issue though


Too bad I didn’t read this post earlier: I had the same problem with parenting certain objects in the game engine. As soon as I unparented them the odd scaling returned to normal. This definitely seems like a bug that needs to be fixed.

Parenting distorts some objects, but I don’t think the answer is not to parent when you just have to set the scale properly. Ctrl-a is probably the easiest, I just always forget it and use the object menu, which also works for me. I’ve also had this happen on uparented objects sometimes.