Astroview v1.0 - Dynamic View Constraint Tool


Astroview is a modal operator that lets you jump to focus points so that your working area is always in front of you. Try it today 50% off!

Learn more:



2 Likes

It looks interesting but I need more information.
Will this operator work when extruding Bezier Curve nodes?

It does not support curves at the moment but will add that to the list, maybe I can have it focus on the active bezier point.

It would be nice if we could change the hotkeys. My spacebar is already used by sculpt wheel.

I will add an option for that in the preferences. Will send update soon, I just want to make sure upcoming features are included as well.

Sounds like a handy workflow using this add-on.
Unfortunately I am having issues using it, or edit: now it works, but it is producing a lot of errors in the console… Using the stable 2.90.1 for the test: The add-on is activated within the preferences, but already without starting it via clicking on the button, I am getting these errors in the console just by mouse entering the 3D view:

File "C:\Program Files\Blender Foundation\stable\blender-2.90.1-windows64\2.90\scripts\modules\bpy_types.py", line 808, in draw_ls
    func(self, context)
  File "C:\Users\User\AppData\Roaming\Blender Foundation\Blender\2.90\scripts\addons\astroview.py", line 1040, in draw_header
    row2.prop(context.scene, 'modal_status', text ="", icon = icon).enabled=False
AttributeError: 'NoneType' object has no attribute 'enabled'

When I click the button, the camera zooms in all the way and this error occurs:

File "C:\Users\User\AppData\Roaming\Blender Foundation\Blender\2.90\scripts\addons\astroview.py", line 88, in draw_callback_px_text
    ob = bpy.data.objects['Cloak']
KeyError: 'bpy_prop_collection[key]: key "Cloak" not found'

which gets repeated on any mouse move. I can zoom out and the add-on does work, but the last error just keeps on popping in the console. The previous errors keep getting recorded as well. On escape, it behaves as before - “just” the mouse enter errors.

Maybe these errors can be avoided and could the initial camera be a bit more distant? Currently, it starts within a default cube.

Thanks

[it doesn’t work for me in 2.92.0 Alpha, but I guess, that is another story]

1 Like

Hey, thanks for the bug report. I am checking it now, I will get back to you with an update.

Edit: Okay I send v1.1 updates to everyone.

1 Like

Thanks, the errors in the console are gone!
…this landing within the default cube on activation though.

Note:
When I deactivate and activate Astroview again, it doesn’t lock to the last point right away, I have to set a new point via space first. Would be nice, if it would lock to previous set point when reactivating. Thanks.
But I am afraid, I won’t use Astroview that much atm as I am using the Blender 2.92 Alpha and Astroview doesn’t work in the Alpha as mentioned previously… :man_shrugging: But yeah, I know - I can’t/won’t expect support for Alpha versions out of the box. :wink:

Thanks!

Thanks for the 2.91 update!
Within 2.92 Alpha it works now as well :+1: …
…except for the initial zoom in, which still happens here (e.g. camera moving into the default cube).