At end of render, image brightens & goes out of foucs

I have got into an odd problem. I have been rendering a character (originally from Blender Swap). It is fully textured (skin and clothes). I have been trying variations with the node tree for the skin material (using ColorRamp & RGB curves.)
The World consists of he renders of a large curled-up plane, strength=.6 and AO fac=.6.w
The renders were going well when one of them at the last second suddenly brightens up and then goes out of focus. So I am lumped with this somewhat blurry image whereas during the render process, the image was crystal clear.

What might be the problem?
Help will be gratefully received.

Have you any nodes in the compositor affecting the final render ?
Have you tried disabling Composite and Sequencer options in the Render / Post Processing panel ?
Have you changed from the default Color Management settings in the Scene panel ?

Thanks for the comment, Richard. But I am not using the compositor - just material nodes.
I have not changed the scene nor accessed the Post-processing nor changed the Scene panel.
The odd thing is that I have an earlier version of the file which does brighten up at the end but the clarity remains.
I’ll try and attach the file.

I tried but I soon got a message “upload failed”. The size of my file is 7.7 MB.

I should mention that in Camera perspective, the 3D window shows a red dotted border though in the camera panel, the border button is not ticked. There is just one camera.

Reduce the included geometry then. There’s also compress option in file -> save as dialog.

I know you said you’re not using the compositor, but it really does sound like a compositing node just because it appears on the render at the very end. As you said, the model came from Blend Swap; while you might not be using compositor, perhaps the original author was. If you can’t upload the .blend file itself, perhaps a screenshot of your node editor could be useful for troubleshooting?

I’ve attached a screenshot from the Node Editor of a .blend I’m working on that has a compositing node activated. I apologize if this sounds patronizing - I’m not sure of your level of familiarity with Blender and I myself am fairly new to it - but if you click at the compositing section in your file (yellow arrow in my screenshot) and see something like this, then the file’s original author added nodes before you downloaded it.




Thanks, JA12, on the file size suggestion. Will keep in mid next time.
Tyto Alba, I think you’ve hit on the solution - something I would not have dreamed of !
I clicked the composite node button (for the skin) and voila an elaborate nodetree popped up.
I disabled the Defocus and Glare nodes on that tree. The final blurry image was gone - a big relief.
Some of glare still remains but though it doesn’t remain, why is it there at all after deleting the Glare node?
Thanks a lot for your suggestion.
I am attaching the node trees.

As an experiment, try setting the Start Frame to just a few frames before the flare-out occurs, and turn on Stamp so that you can see actual frame-numbers for reference. Does the flare-out continue to occur, and at the same place? (betcha it does …) If so, then you have something that’s driving it … and, myself, I wonder what you might see if you flipped over to the VSE window.

Remember also that in Blender, now, e-v-e-r-y-t-h-i-n-g can be animated. (“Domo aregato, mis-ter Animato!”) Perhaps there’s a keyframe affecting one of the variables. The “Graph Editor” and “Timeline” windows can help you look for this.

Sundialsvc4, the fact is the flare-up (or glare-up) occurs right at the last second of the Render. So there is little to follow up.
Having removed the Glare composite node, the glare has reduced a good deal though why it has not disappeared is a mystery.
But more important, the out-of-focus image (also occurring at the very last second) is gone after disabling the Defocus node - thanks to Tyto Alba…
I really appreciate Tyto’s brilliant diagnosis that the problem must lie in the composite nodetree and so it was.

Edsa, I’m glad I could help!