ATI and Blender - Still a bad combination?

Hello, does anyone know if the problems with the ATI graphics cards and Blender are still around? I have a Radeon HD 5450 still in it’s packet.

Thank you

Since the latest driver (10.6) the blender interface works pretty much even with compiz turned on, at least with my card (hd4570) and kde’s version of compiz.

I have recently bough a laptop with hd5450 mobility version (+Ubuntu 10.04+default Ati drivers). Played with Blender a little bit on it and haven’t noticed any problems.

I have some problems with game engine: using double UVs dont works on some ATIs.

With the 2.5 alphas I’ve been having serious interface/graphic draw problems. The window will just randomly go gray and I’ll only get little flickers of the buttons or 3d window when I hover the mouse over. It’s possible this is a bug do to the alpha that hasn’t been fixed but I’m pretty confident it’s specific to my graphics card which is an ATI Radeon X300/X550/X1050 series.
I’m not sure if I have the latest driver updated though, because that machine isn’t hooked up to the internet and the driver update software works by automatically checking a website which is a little frustrating so I’ve had to update the drivers manually and not sure if it’s the latest one.

But I’ve tried all the different draw modes in the user interface for Blender and nothing seems to help. I’m planning to get a new Graphics Card anyway because I need more graphics memory on that computer, so it’s not really a major issue for me to find a solution for, but I just wanted to warn you.

At least on windows XP, vista and 7, i’ve no problems with Blender. I’m using an HD 4830.

I get this with an Nvidia 260GTX with the latest drivers, I think it’s an issue with Blender itself.

That’s what I’m kind of hoping, because 2.5 is still in unstable phase so possibly this is something they still need to fix. The developers have a ton on their plates right now though so I’m not holding my breath for a bug-fix anytime soon.

Mobility radeon HD 3400 works smoothly with the latest driver under Kubuntu Lucid but with no desktop effects turned on. It can work with these effects but the system becomes less responsive (at least to my needs as I cannot wait for a second or two for a window to display).
Strangely enough, though, the same graphics card works fine under Gnome on the same system! I really like kde but I’m seriously considering switching to gnome (esp after seen stunning clear type fonts).

In my Toshiba Satellite laptop (with ATI Radeon X1250), Blender is too slow. Moving any objects is a real pain. I don’t know what the problem is. :frowning:

have you tried changing the drawing method in user preferences (that is, if you can even get that far)?

I’ve had zero problems with my 5770 which is in the big brother of your card and uses the same drivers.

So far the only ones having issues to my knowledge either have older cards or crappy laptop GPU’s like demohero

Yes, it has similar problems on every draw mode… it changes slightly but I basically get around to the same issue regardless of what draw mode I set it too.
I should try the newest SVN though, I haven’t run any new version on that machine since around April. I’ll try and do that today if I get the chance and report back to see if there’s any change.

I just tried the latest SVN and played with it for about 10 minutes… previously it would work fine for about 4 minutes and then all of a sudden stop drawing the interface, but it looks like MOST things are working now in Full Draw mode.
Although I could just be getting lucky, but I’m still having issues with Sculpt mode. As soon as I sculpt anything the model completely disappears from view, and changing draw methods doesn’t appear to help.

Edit: Also if I expand the window with the toggle full screen button the entire interface gets really glitchy.

So far works great for me on Windows 7 (64-bit) ATI Radeon 5780, but I haven’t had a chance to truly test it with a large project.

That is a very interesting thread for me, as I have experiencedTons and tons of problems between Blender and my ATI x1950Pro.
_ Very similar to Consideringtheprickle
_ Distorted images in the UV editor under certain circumstances (too often), depending on the level of zoom
_ flickering images in the UV editor, depending on the level of zoom

All that in 2.49.
I can’t use the latest ATI drivers: they are not aimed at my 3 years old (but still very capable) x1950

I was considering switching to nVidia…

I have a mobility HD 2600 and it works perfectly under vista with the newest driver. On the other hand I can’t get GLSL to work under ubuntu, but all other functionality works fine.

Okay, thank you everyone for the help you’ve given me. I think I may stay with the ATI graphics for now. I may swap it for an Nvidia card later if I need to.

I have EAH 5750 Formula and going WELL and STRONG ;). No problems so far. In fact I think that ATI is better choice for now because of a price/speed comparison.

 JayM

PS: Win7 x64 system

Make sure that you test sculpting with ati graphics cards, because I’ve heard of some problems with that.