ATI FireGL Z1/X1/X2/T2 Card solution to Blender problem!

I have been struggling to get mine to work properly. Now Blender runs BEAUTIFULLY!

Follow those steps:

  1. Uninstall all of your ATI drivers for your FireGL card
  2. Reboot your computer
  3. Download this old driver --> http://drivers.soft32.com/driver/download-Ati_FireGL_T2_X1_X2_Z1-24097.html
  4. Install it and reboot your computer
  5. Have fun blending!

It should work! It works awesome for me now! :smiley: ATI isn’t that bad if you know how to work around.

Please let me (us?) know if it works or not! I wanted to contribute my discovery for all ATI FireGL users. :slight_smile:

Many thanks to #Blenderchat for their help too!

THANKS! :smiley:
I will use it when I never get a fire GL! Well, maybe one day I might get such a workstation :P. Merry christmas, to you, one of the #blenderchat chambermaids :wink: :stuck_out_tongue: .

Good fiz, this applies to all ati drives if you dl the version prior to 4.4.6 (I think) it will work. But of course, the best solution is to get a kickass nvidia card that’s way better anyway! :wink:

but won’t going back to old drivers give some instablity in other areas apart from blender? A lot of bugs are fixed as drivers are updated, so it just seems like that.

Will this driver work with the ATI Xpress 200? I have a motherboard with an integrated ATI video chip.

Updated News:

I now remember why I updated my ATI drivers… the version I told you about is very instable and you get fatal atiglgl.dll error and will require you to restart windows and it will crash again afterward… very bad. So, I had to update my drivers back to current one.

I’m going to try other workaround… I’ll let you know if my idea works…

Edit: I tried t put atiglgl.dl_ (expanded) from old driver into blender directory and blender wouldn’t open at all. I’d get an error and it performs just fine when i deleted that atiglgl.dll there. I can’t find atiglxx.dll in firegl driver. Does anybody have any ideas? And yes, I tried radeon’s atiglxx.dll as well… didn’t work either.