ATI, open source drivers and slow selection: Is it the card or the drivers?

Well, I guess many of you are familiar with the problems one can encounter in Blender when using an ATI card… The most common is the “slow selection” bug (examples: and If it’s the GPU’s fault, then I guess I’m doomed :slight_smile: But if it is the driver’s fault, can we hope for an improvement, now that ATI has open-sourced its drivers? (please say yes :P)

I think its the drivers not the card, which is why changing drivers can solve the problem (some of the time).

ATi open sourced its drivers? When did I miss this?

I’ve got 2 HD Radeon 3870s in crossfire. I know exactly what you mean.

Man… why’d I have to go with ATI???

ATI have open sourced their 2D drivers not the 3D, so we have to wait.

I have an ATI 9700 pro running at 1920x1200 on Ubuntu 5.10 without any problem.

Ubuntu 5.10? Wow :slight_smile: Yes they say the best driver to use in Linux is the flgrx (or something like that) one, but unfortunately it only works for cards older than HD2xxx series… I’ve tried every driver available for my HD2600 and each failed majestically :stuck_out_tongue:

Are you with Ubuntu ? If so, have you try the Envy ?

ok is anyone experiencing a problem similar to mine i have ati7000 card so when i first got blender it was so slow than i fixed it by getting drivers from nivida and renaming them and it worked my blenders faster than ever ie for modeling compositing texturing but theers a problem with the game engine that is all games made by blender run really really slow on my pc now the ojnly problem left to fix is speed up the game engine i feel so frustrated ive tried everytrick to fix it but itseems the game engine remains slow but modeling and everything else works fine anyone else got this problem ?

@blenderrenegade: Sorry mate, can’t help you :no: But try to use punctuation, it’s hard to make sense when you only use space for seperating words :stuck_out_tongue:

I had this other idea… Could the slow selection problem occur due to a potential bottleneck (isn’t that the word?) of the CPU? Maybe OpenGL with this card puts more weight on the cpu for some reason than the gpu…(this might have sounded) ? My CPU is AMD Athlon64 3000+ (1.8GHz)…

lol bro (i never use punctuations because i am the blenderrenegade and apart from that its exactly as i would say it in real life no stopping or pauses or anything but just a big long sentence ) ok try googling the word bottle neck and youll get its exact meaning bottle neck cannot and is not the problem (unless your using some anncient computer ) but the slow selection problem is the resultant of some accient methods of instructions used by blender which is not related to the cpu but related mostly to the display driver hence (gui problems)

So you think this could be resolved by corrections/changes to the Blender code or are we doomed to wait for ATI Catalyst 9.9? :stuck_out_tongue:

Doomed. The next driver release probably won’t fix it either. I don’t really know all the history but it’s apparently not fixable by the Blender devs and ATI probably couldn’t care less if Blender runs or not.

Btw the Nvidia or other drivers trick just saves you from having to manually disable acceleration. You can do the same by copying and renaming any dll in the Blender folder to atioglxx.dll.

This seems to work but it is actually just using processor power and not the graphics board, so the quick response goes away when you start moving around in a real heavy scene (although the menus do stay quick).

So I figure that’s the prob with running Blender games as mentioned above… using the fake driver trick is the same as running a game with all acceleration turned off on your graphics board.

I really feel doomed allready. Doom doom da doom. And now that the 3850/70 are out with lower prices than my 2600 no one buys it. Argh.