attribut ERROR solved but new one arises :( :(

my script was working ok till the recent trunk over 35543, i get this error on every custom property i did:

Traceback (most recent call last):
  File "\io_import_lipsync_imp", line 273, in draw
AttributeError: pyrna_struct_meta_idprop_setattro() can't set in readonly state 'Scene.fpath'

any tips on that would be nice of you :o

OK it’s been a week and no answer, doesn’t anyone know the problem :frowning:

make it easy for people.

  • provide a link to the full script

sorry and thanks for the concern, but i solved the problem :slight_smile: , i just moved the declaring of the custom property out of the draw function and it worked again.

but i found another problem:
i used this len(bpy.context.active_object.data.shape_keys.keys) to count how much keys an object has, now it gives me this error even in the console:


Traceback (most recent call last):
  File "<blender_console>", line 1, in <module>
TypeError: object of type 'Key' has no len()
 

keeping with api changes is hell without an API changes log

Indeed. What you want seems to be…


>>> len(bpy.context.active_object.data.shape_keys.key_blocks)

I’m unfamiliar with the classes dealing with shape keys, but it’d make sense that a ‘key’ attribute would get renamed to the more descriptive ‘key_blocks’, as to not be confused with the ‘key’ method used by mappings.
Here’s a gratuitous link to the docs --> (Link.) :eyebrowlift:

QUOTE]key_blocks[/QUOTE]thanks man i knew that there is been a change in the api to avoid conflict,
but i didn’t know where, and now it works again.