audio hiss

I’ve got a problem exporting my animation with sound. Theres a hiss to my music and sound; it sounds terrible. I added .wav files to the sequence editor. And configured my export settings as follows:

FFMpeg

VIDEO-
Format
: AVI
Codec
: Mpeg4(divX)

AUDIO-
Multiplex Audio is enabled
Codec: PCM (though I’ve tried them all)
Bitrate: 128 (though I’ve tried much higher)

I also attempted a MIXDOWN and the exported .wav sounds terrible too. What am I doing wrong??

Decius your bitrate is wrong. The wav sound you’re trying to import to Blender could be of a low bitrate, lets say a bitrate of 24. So what you do in Blender is change the bitrate to 96, because as you know 24x4=96( actually you could also do 24x5=120, yeah I suck at maths, I’ve only got ten fingers).

The higher the bitrate the better the sound, so 128 bitrate is the top sound. However, not all bitrates fit into 128, that explains the example I just gave. Good luck!:stuck_out_tongue:

kay’ thanks ozo. I’m not that informed about sound obviously. but strange…
I tried 120 bitrate and blender crashes every time, no matter which audio codec I use.

And the .wav is most definitely 24-bit. I double checked in Audacity. Strange how it will export it with the improper bitrate set but not with a correct one. And a crash for that matter?!

I was able to get 96-bitrate to work. However, same problem, theres still a nasty hiss? Any ideas?

I will say however, the hiss DID reduce. but it’s still pretty much there. Perhaps now the problem is that the bitrate is too low. But blender won’t let me choose any acceptable value higher than that without crashing! what do i do?

You got me there Decius. 96 bitrate worked for me. I’m stumped.

The other thing you could try, is change the Sample Rate in Audacity itself. Say change the Sample Rate from 24 to 16 bit, or even to 32 bit. Try one of those. It’s worth a try.

But I wouldn’t change the Project rate in Audacity, sometimes it lowers the quality of the sound.

I tried that too. No Luck. Does anyone else experience crashing for 120 bitrate or < in blender like me?

After spending more time digging deep into the numerous amounts of threads on audio problems… I’m starting to see that Blender has a plethora of audio problems and mine seems to be a small straw in the stack. Perhaps Blender is lagging a bit on proper audio support? Regardless, I couldn’t find ONE thread about a hiss or anything to the like… and it seems theres not much light on the subject on the wiki either.

It seems that most people come to the conclusion to mix audio and video in a separate app (ex. VirtualDub or a commercial alternative). If this is the only way to complete my project, it will make for the first (and hopefully only) time blender has let me down :frowning: I’d like to think it’s not true. In the past couple years I’ve been blending it has always proven to provide EVERY need as an animator, without having to use other third party software (except for 2d work of course). This is exceptional considering I can’t say the same for when I was using the commercial app 3ds!

Someone plz let me know if theres a way!

With 2.44 I do all my mixing inside Blender. You can now do multi-track mixing with sliders (variable volume).

outside of Blender, MAGIX has a great set of de-hissing tools. Audicity might as well.

Problem is though, it’s blender that’s causing the hiss. The wav file is quite clear, I recorded with some very nice equipment in my brothers recording studio.

It allowed me to go with 192bitrate without crashing… Still the same nasty hiss, no better. So I’m ruling out that its due to a low bitrate.

Here’s a link to a brief snippet if it helps anyone get an idea.
http://studentweb.eku.edu/mark_ballenger/soundtest.avi

I’ll also note, and I can’t say this for certain: It sounds like theres only a hiss in the music… the voice doesn’t sound bad (but it’s hard to tell judge this by ear, even when listening to them separately).

Okay, I made headway, but I’m not outta the woods yet… this may be partly to my being confused as to the difference of Audio(HD) and Audio(RAM).

The first paragraph of http://wiki.blender.org/index.php/Manual/Audio_Sequences tell me Audio(RAM) is for adding wavs and Audio(HD) is for adding sound from movies.

So I followed this teaching and added my wav with (RAM) which gave a hiss. Just to experiment I tried adding it with Audio(HD)… NO HISS!!!

However, now I am experiencing crackles and pops at regular intervals. Anyone know anything about that? And can anyone explain the difference between these two audios better than the wiki? And maybe improve the wiki while you’re at it?

Here’s a new link to the Audio(HD) file:
http://studentweb.eku.edu/mark_ballenger/soundtest2.avi

Okay! Through experimentation I have resolved these audio conflicts. However, it makes no sense to me as to why what I did works! Can someone smart try to explain this?>>>

I jumped over to the soundblock buttons and changed the mixing/sync to 48.0 kHz and hit “Recalc” (not for sure what exactly recalc does honestly, just thought it might be necessary for the changes to take effect)

… But my wave’s sample rate is 44.1 kHz (done in Audacity)… ??? … why does it work better in blender with 48.0 kHz? And further, what about the Audio(HD) and Audio(RAM) thing?

cackles and pops i think is the hardware not able to keep up with the bitrate.

Decius, yes I can hear that tick, tick sound in your “Test2.avi” movie. The tick sound is subtle, but you can still hear it. How about posting the wav file instead, and maybe someone can make it work.

BTW, animation is not bad. You can tell you been reading up on animation, as always have two walls in perspective in your camera view.:slight_smile:

Yes, the test2.avi is the one with the crackles and pops that I referred to. I didn’t upload the fixed one. But it is flawless. I am happy :slight_smile: but like I said, I don’t understand why it works with those settings…

when I’m finished with the entire thing tonight probably I will post it on the completed works forum if ya wanna check it out :slight_smile: It runs about a minute and a half in length

I’ve never heard this before. I suppose it’s a good rule of thumb if you’re trying to establish a perspective, makes sense. For purposes of this product demonstration however, I wanted a very simplified environment so as to force the viewer to watch the door. (there’s a gadget that’s placed on the door in a later portion of the animation.)

so, Audio-RAM loads the audio into memory for faster playback (easier time scrubbing since you dont have HD latency/ read delay) but takes up memory. Audio HD reads and plays from the Hard Disk…?

Also if you update the file on the HD, the changes are reflected right away, whereas you have to do a reload if AudioRAM is used.

but you are saying that Hiss is introduced sometimes if Audio RAM is used. Interesting - there must be some decoding or sampling going on, that does not occur when Audio HD is used.

You do know that a WAV file is simply a bunch of numbers that when sent to a DAC at 44khz and the A side of the DAC is hooked to a speaker through an amplifier, you get the sound. Sort of like a tape recording converted to bits.

Thanks for that explaination PapaSmurf, I never knew the difference between those two. But now that you’ve explained it, it seems so obvious, why didn’t I pick it up before: AudioRam from the memory and HD from the Hard Disk.:slight_smile:

Decius, sounds like you got your problem fixed. About that perspective stuff that I was talking about, I was refering to that Brad Bird pdf (you know the guy who directed the Incredibles movie).
The title of that pdf is called Storyboarding the Simpsons way. Here’s a sample of what I mean. Try google, you’ll definitely find a copy.

Attachments


cool. I love the Simpsons.