Auto Delete

So good! I always wanted this! thank you very very much!

thanks for the plug - fast and handy :wink:

Update :
-1.Corect delete alone vertex
-2.Delete object without confirmation
-3.Delete curve vertex

download - https://github.com/Darcvizer/Auto-Delete-for_Blender

In my opinion this addon should replace those hotkeys when you install it, makes thing so much faster and easier for end user.

Nice add-on. Thank you.

OMG. Thank you very much.
These menus for confirmation are disgusting, useless and a very bad idea.
I had to config a shortcut for each type of object to delete just to not see these menus. A simple delete operation took away my peace.:mad:
I’m really happy with this addon.
Finally… I can relax…:slight_smile: :RocknRoll:

update 2.8
auto install hotkey if use default keymap

Auto-Delete-for_Blender28.py (4.0 KB)

or

2 Likes

I just tried installing this and the console says it installed fine but hitting X on a vertice/edge/face does nothing. I tried leaving the default hotkeys turned on as well as disabling them. I also can’t seem to find it manually in View3D > Add > Mesh > Auto Delete.

Any idea where I could look to see what the problem may be?

For 2.8
Try create new hotkey in general 3d view

id = mesh.autodelete_ot_darcvizer

1 Like

That worked perfectly. Thank you!

Thank you I will try it again

It should now work with any configuration automatically.
In case of any problem, write here, I want to do so that there would be no need for absolute actions from the user

Auto-Delete-for_Blender28.py (4.0 KB)

1 Like

Thank you for exposing an easy-to-use tool.

However, I think that it will stop working when installing and rebooting.

I had the same issue when restart blender 2.79 stable.
had to delete and reinstall addon to work.

I understand what the problem is but have not yet found a solution.
You must manually make a hot key and disable the deletion on X

in blender 2.79 stable, I follow the same instruction for blender 2.8 to create " Add New", input the ID"mesh.autodelete_ot_darcvizer" and assign hotkey “x”. it works like wonder now(restart or reboot, all works) !!! thank you very much Darcvizer for creating such useful addon.

1 Like

Thank you
It started working perfectly in 2.8.

Не работает на последней сборке.
235252

Как то я пропустил это, сорян.
Я только что проверил на June 06, 01:36:50 - 8b2b79c2108b, все работает, только вам надо выключить стандартные хоткеи удаления если вы используете “X” или “Delete”.

I just checked on June 06, 01:36:50 - 8b2b79c2108b, everything works, only you need to turn off the standard hotkeys of deletion if you use “X” or “Delete”.

Отключил X и Delete, сборка за 06.06. Проблема осталась та же. Такое же сообщение.