Auto IK - cannot move bone in pose mode

So for example, I select the main hand bone and press G and move the mouse… nothing.

I can rotate with R, and the hand rotates around the wrist, obeying the constraints I have set in place, but I cannot move any bones along the chain.

I’ve tried moving upper arm, lower arm, hand, each part of the finger… nothing.

I have “auto IK” ticked, and “Manipulate center points” is not selected.

What am I doing wrong?

What rig is this? IIRC, Rigify based rigs (or at least earlier versions of it, like those used for Sintel) were constructed in a special way so that various pose locking/control features could be added, but those features have the effect of breaking the chain, making it impossible to use AutoIK on those rigs.

It is a rigify rig (Edit: not a rigify rig), but I have had the auto IK working before. I made this model in April/May and upon returning, the bones don’t move like I remember.
Another thing that might be noteworthy is that in the bone section of the properties panel, all of the location transform locks are greyed out, as are all of the IK settings of the same panel.


all of the location transform locks are greyed out, as are all of the IK settings of the same panel.

That means Auto IK disabled all other IK setup on the rig. Otherwise you got several IK setup working all at once!

So for example, I select the main hand bone and press G and move the mouse… nothing.

Are you sure you selected main hand bone? If you selected main hand IK target bone you are moving the target, which is deactivated by Auto IK. Target will move but nothing more.

Even when I diable (‘untick’) auto IK, those things are still greyed out.

I don’t have any target bones (I don’t think). Also, the bone does move, it just doesn’t bring the other bones with it. If I select the hand bone, press G and then move the mouse, the hand sort of rotates around the wrist, but I cannot drag it away to straighten the arm or whatever I want to do. The upper and lower arms behave as though they are locked into position and rotation at all times.

So if I select upper/lower arm and press G, I get no movement at all, only the hand will be responsive.

If you’re using rigify you should have plenty of targets. The whole point of rigify is that it already has all of the IK and FK and switches set up for you. If you’ve made a lot of manual changes to the generated rig, then you’ve probably broken it. Or are you justusing the meta-rig? That’s not meant to be a usable rig for your character; it’s just the placeholder you use to tell Rigify where it should generate the full armature.

I am using the meta-rig, and I’ve been using that the whole time. Let me repeat that I have had IK working fine with this set up before. It’s only since I updated Blender a few weeks ago and went back to this old file (from april/may this year) that things aren’t working properly.

I have some good/interesting news though. On a whim I tested out all of the other bones and it turns out that all eight fingers and both thumbs are working with auto IK as expected/intented.

Which means it’s only the legs and arms behaving strangely/not at all.

why do you have auto IK if your using rigfy rig? it has IK built in.

Well, as I said, don’t use the meta-rig. It’s not intended as a functional rig. You just use it to generate the Rigify rig. Don’t use tools improperly and then complain that they don’t work. This is like trying to saw through a plank of wood using a balloon instead of a saw and complaining that it won’t cut right.

I am sorry, I was mistaken. It is NOT a rigify rig I am using. I simply used the rigify human meta-rig to provide an armature, and then I did all the weight painting and constraints for that armature myself.

I didn’t realise you could actually generate a rig with rigify, that’s why I misinterpreted the question.

I guess what I’m asking now is how does one make a custom rig, where have I gone wrong? Why does auto IK work for the fingers, but not the rest of the arm? Why is the inverse kinematics panel greyed-out regardless of auto IK settings?

If you want to make a custom rig, start from scratch. Do not use the Rigify Meta-Rig. That’s where you went wrong. The only reason to use the Meta-Rig is to generate the Rigify Armature. It has scripts and stuff associated with it, and is not intended as a usable armature for animation in its own right. And at this point if you’ve messed around with the Meta-Rig in your scene, you probably need to delete it and start with a fresh copy if you want to generate a real armature from it.

So it turns out that even though the IK settings are greyed out, they are in effect.

I had all the rotations locked into place on the upper and lower arms and legs… I don’t know why. Sorry for any wasted time.