auto-ik hot-key?

Can some one give some hints on how to toggle auto-ik on/off (with hot-key)? It isn’t in the default keyconfig. Thanks!

Got this to work using wm.context_toggle (in the pose section (context?) of the keyconfig), and Not sure why armature.use_auto_ik doesn’t work - maybe because its a tool panel option?

“armature” is not a context member

note the capital A, it means it is a type:

(see “References” at the bottom)