Auto Keyframing Issue

So when I press I instead of getting the Rotation, Location, Scaling menu it just automatically inserts a keyframe which I wouldnt mind only this doesnt seem to work for objects only armatures. I have gone to user preferences - editing - and disabled auto keyframing but that did not remove it. Any help is much appreciated

On the timeline, if this box isn’t empty, empty it. It should solve your problem.

That worked, thank you your a lifesaver!