Auto-rig Pro [3.56]

@dzim Please see here for root motion export:

There are no functions yet to retarget multiple actions at once, sorry.

@RepentToJesus It seems the UV mesh data are invalid for some reasons. Is it possible to send the file for investigation?

Sorry japanese characters may be not supported, it has never been tested, at least on my end. Maybe other japanese users could testify.

@Splododyne Thanks for the feedback, it’s not possible to define default auto-stretch values. However it’s rather quick to modify: select all IK controllers, hold the Alt key then set the value to 0.0.

@juggie Hey thanks for your interest in the addon, adding it on the Gumroad platform is yet planned, but this may be done if this is requested by a lot of users. Actually this is more work to maintain two product platforms than a single one. Why don’t you like Blender Market?

Well, it worked to build a bone list only after I renamed all Japanese letters to normal letters. Which I just finished right now.

@lucky Sorry for the late reply! I sent you the project file over E-mail.
It’s most likely just a simple mistake that I haven’t been able to figure out. :blush:

Hi Artell, cannot install on blender 2.91 is it compatible or i have to get to 2.9 for it to work?

OK i found the issue i didn’t know i had to create another folder to extract the zip

Hi again i am having problem with rigging an arm alone so is this even possible with this addon?

I put the arm model at the center of the world 0,0,0 and i applied transform to it and when i select human it do nothing and i cannot draw the green circle anywhere on the arm. Your manual mention turning off mirror but i don’t see this option anywhere in the auto rig UI.
Once i have click on human all the options get grey out and i cannot select again

I am working at 0.01 scale in blender and i was able to see the marker but cannot move them at the correct locations so i don’t know if i need to work at blender default scale of 1.0 for this to work and it’s for exporting to ue4.

edit: i was able to make it work with a full character at 1.0 scale but if i select the bone after binding they don’t show the axis for rotation or moving and the hand bones seem screw up here a picture also i was not able to select the mesh in viewport to bind, i had to select it via the outliner.

When I Bind my mesh to the rig I get unwanted deformity of the left arm and left leg. What am I doing wrong, please?

Edit: This seems to happen only when using Optimize High Res option (checkbox). The mesh is 147000 triangles, the Polycount Threshold for the option is set to 70000. After its finished binding however, the mesh doesn’t move when I move the rig in Pose Mode. So the problem is now, mesh doesnt bind properly. Any ideas why it wont bind properly, please?

Edit2: Enabling the Scale Fix option fixed the inability to Bind. Still getting warped arm and leg though. The warping was fixed by clicking Match to Rig.

@lucky I have an issue when trying to rig my character. When setting up the reference rig, after clicking match to rig, the control bone rotations get messed up, even though the reference bones are rotated like they should be. You can see what I mean in the attached image:


Is there a way to avoid this uncontrollable auto rotating?