Auto-rig Pro [3.59]

Anyone have any tips using Brekel mocap and retargeting with Auto Rig Pro? Mesh gets odd deformations, IK is turned off BTW.

@lucky I recently started having this warning in Unity when rig is set to Humanoid:


For various reasons, the rig must be set to Humanoid, so changing it to Generic is not an option.

In my Blender file there is no scale keyframes anywhere, and all of the stretch channels are set to their default value and keyframes are deleted.

These are my export settings:

I also tried lots of different settings, mainly changing Simplify Factor, Fix Rotations and Initialize Fbx Armature Rotation, and every time i Checked and Fixed the rig.
I’m currently using Auto-rig Pro 3.60.13 but this was also happening before with 3.56.17.

No worries these are harmless warnings, most of the time because the animation baking outputs scale values with numerical imprecisions, leading to 1.0001 or 0.9999 values instead of 1.
I’ll see if it can be fixed anyway by rounding values close to 1 so that it doesn’t lead to any warning.

@lucky Hi there! First of all congrats on the amazing job, the plugin is awesome!
I have searched the forum and the documentation but i did not find an answer to my question.

How can I use the remap function with a linked rig? I would like to keep my character and rig in a different file from the animation/scene files, so I can make changes in the character and have all the different scenes where its in automatically update with the linked file.
I tried with proxies and library overrides, but I get an error saying the plug in couldnt freeze the target armature.
If I append the character/rig file, ARP remapping works just fine, but not if i link the file.

Am I missing something here?
Thanks a lot and congrats again!

Adonis

This is not like Hair shape keys addon update. That man updating his addon to be compatible with 2.9 and selling updated version to his old customers. That is something like you should complain more about. But this man relasing some addons like revolution in itself.

1 Like

Hİ. İs there a way to rig double sided laterally located eyes properly? for example in camel the eyes looking opposite sides. How should eye rig these eyes?

@lucky There seems to be an issue with version Auto-rig Pro 3.60.13, and Blender 2.91 when Applying the Redefine Rest Pose. Here’s the error after hitting the Apply button:


This issue doesn’t seem to be happening on 3.56.16, and Blender 2.91.
All the armatures, rigs and mapping presets were exactly the same, the only difference is Auto-rig Pro and Blender versions.

@Luka38 Sorry for the troubles, I’ve just commited some fixes in the latest version, please test it.

@Adonis_Comelato Make sure to remove keyframes on the armature object, and reset its transforms (location = 0, rotation = 0, scale = 1)
Thanks for the feedback!

@asaanimation Sure, the eye direction is defined by the “eye_offset_ref” bone (in the middle), just make sure to set its rotation the way you need it to be.

It seem to be working now, but the mesh gets messed up after Re-Targeting the animation. The mesh goes back to normal after I refresh the file of the proxy rig in Blender File display mode.
Other than that, everything works correctly.

Issue with “Quick Rig” addon. Imported fbx of Reallusion Character Creator 3 character with UE4 armature. Used Quick Rig, but the alignment of the armature is off.

Quick Rig is not always ready-to-use.

You need to modify the skeleton to some degree to make Quick-Rig functionality feel natural.

@Luka38 Yes there are a few known issues like this when dealing with proxy armatures, the animation data update being not triggered properly. I’m not sure I can resolve it it seems intrinsic to Blender dependency graph but I’ll see what I can do.

@lechinhc The CC preset is meant to work with default CC skeletons. Maybe the UE4 setting is changing bone axes which is not supported, in this case add limbs manually. Please send the blend file for support:
http://lucky3d.fr/auto-rig-pro/doc/bug_report.html

@lucky I’m having an issue after Re-Targeting a Mixamo rig animations, my rig’s IK feet get flipped:


I have no idea why this is happening since I have same process for every model I rig.
I always just add the Human armature and then just reposition the bones.
All of the bone rolls for the legs are almost the same as the the base Human armature.
I have tried remapping some other fbx files, with Automatic Bones Orientations option turned on and off, and always the same result.
Also tried some Legacy options when Matching to Rig, no luck.

don’t know if you solved this issue but if not i found the problem. in the control panel look for eye object and make sure you have arp_facial_setup in the box. hope this helps

As I learn to use this tool, I am thrilled/amazed as to your thoughtfulness of purpose in all things available to me. You’ve made rocket science not feel like rocket science.

A question: I am getting twisting in the bicep; how might I lesson or mitigate that?
Thanks for all you do.

This is a beautiful tool this auto rig… im exporting to unity… rig always comes in fine. i made simple animations to export . Pushed them down into NLA… i go to export via the Auto rig pro fbx method and it doesnt pick up that any animations are available… the rig transfers beautifully… but no animations… any tips ? been looking around…