Auto Rigging issues

OK… what am I doing wrong…

  1. I use the human metarig and form it to my character (line up the fingers, arms shoulders knees etc)

  2. weight paint is to the meta rig (parent–>auto weight)

  3. clean up weight painting as needed

  4. generate auto rig

now, I should just have to change the armature modifier to point to the generated rig
and I can delete the original rig…

but that doesn’t seem to work (some of the bones are named inconsistently)

what am I doing wrong?

Thanks guys…

Haven’t used rigify…so take this from that perspective…

I thought the workflow was create the meta rig, adjust it to fit the mesh, generate the final rig, delete the meta rig. Then if you’re using auto-weighting, find the rigify bone layer that has the DEFormer bones on it and turn on only that bone layer. Add armature modifier to the mesh (filling in the blanks), enter weight paint, select all bones, and from a menu there (forgive me for not looking which menu, but it’s in the header) there should be an option - assign auto weights. That should weight paint the mesh to the DEFormer bones that are selected. Then you can parent the mesh to the armature, choosing not to auto weight.

You might be able to do it by turning on the DEFormer bone layer, select all bones, parent the mesh to armature with auto weighting…

Now, for what I do know: weight painting to the meta rig is wrong. The generated rig has 2 deform bones for the upper arm and 2 for the lower arm. Deformer bones have a DEF prefix to them, so weight painting the meta rig won’t do it.

I’ve seen the work you’ve done with Giants of the Earth, so I know you know your way around blender and hopefully this is enough to get you going in the right direction.,…

Randy

Ahhh – I actually didn’t know how the autoweighting in weight paint mode worked – thanks for the 411!

hi Randy,
first part is the way to create the weighting after the rigify or
one have to change every bone-names, because the rifify-ed rig
has different names for the new bones (those with DEF at the start of name).

Importent! You only get 2 DEForm-bones for arms, legs if you use the defaults.
If you dont want 2 DEForm-bones, you have to set this as option - and because
the default is ON for this option, you have to disable it.

NOW! where is this option?

with the human-meta-rig (before you run rigify) switch to
ARMATURE mode and
for example
select the upper-arm bone.
Then in the window for this bone,
at the bottom, there are the options under rigify options.
They are called for the arm:
upper arm twist
lower arm twist
and the help-message says something about
this is to generate DUAL-BONE for twisting.

Disable these options and run rigify to the armature
and this bone has only one bone (like you wanted).

Now you may easy find the options for the legs
(its only the settings in the upper-leg there too).

hope this helps …

You are weight painting to the meta-rig. You should be weight painting to the generated rig.