Auto Smooth at 180 degrees doesn't smooth where I extruded

Hi, I’m trying to figure out how to make my extruded planes from my model’s edges smooth to the body instead of you being able to see the edge I extruded from while still using Auto Smooth.

What I’m trying to do is- make what I call fur flabs (idk what people call them, hair cards?)
The fur flabs is where the fur will be textured, making it look like fur is sticking out.

Here’s an image to show what I mean. I’m using oppasity maps to create fur on the edges I extruded;

I’ve set the shading to smooth, and turned on Auto Smooth and set it to the highest degree. I did this because I need my model smooth, while being able to mark some edges sharp. I assumed keeping auto smooth at 180° was the same as setting the mesh to the smooth shading, however it seems it isn’t 100% smooth (not including any edges I marked as sharp.)


Here’s what I mean;
This is with Auto Smooth set to 180°


I’ve circled where you can see where I extruded the fur from.


And here is when I turn off the Auto Smooth, so it’s just using the normal Shade Smooth option.


You can no longer see where I extreded the fur from, it looks nice and smooth. ^^




Here’s a clearer demonstration with a sphere.

On the left is Shade Flat, middle is Shade Smooth, and right is Auto Smooth set to 180°.


This is the topology of it. I’ve marked some edge sharps on the Auto Smoothed sphere, but not on where I extruded from.

Here’s the Shaded Smooth and Auto Smooth 180° side by side;

Say I wanted that extruded edge to be smooth while keeping that triangle at the top of the mesh sharp with “Marked Sharp.” I always thought that Auto Smooth 180° was the same as Shade Smooth, but with the ability to manualy mark some edges sharp for some nice details.


  • Sorry if some of my wording/terms are incorrect or if the images aren’t clear, I couldn’t screenshot so I’m taking a photo of my monitor screen.

My question is-

How can I use Auto Smooth while keeping extruded edges smooth?
and
Is Auto Smooth 180° the same as Shade Smooth?

I’d love the keep the fur flabs smooth while also making things like the claws’ edges sharp using “Mark Sharp” without having to split the mesh. I use 180° for Auto Smooth because I noticed the lower the degree is, the more edges look sharp, and at 0° it looks the same as Shade Flat, so I assumed 180° was the same as Shade Smooth.

Any help is appreciated, thank you!

Hello, ill help you, but first i would encourage you to do a decent amount of research on how fur is made. I think you’re using a very bad workflow, one that will cause you alot of trouble down the line, and not yield a good result in the end.


That said, back on topic.

Note, i said “ideally this would not be shaded smooth” at 2:13, keep this in mind, as i meant to say “ideally, this would not be shaded flat”. Dont get confused by that, just a small typo.

The video covers everything about your first question, on how to use auto smooth while keeping extruded edges smooth. I decided to make a video, as some things are far easier to show, than to explain by text.


Second question, if auto smooth is the same as smooth shading.

Answer, is no. Kinda. It applies the same thing as smooth shading, but “auto smooth” is not a “type” of shading, its just a tool for automation.

Lets just go over some basics, most of which i think you already know, but just to set the scene.

If you set an object to smooth shading, you can still go inn and manually set each edge to sharp shading yourself. This is the workflow that yields the most control, by manually deciding the shading on every edge yourself.


Lets take this simple object, as an example, its very obvious that you want to use a mix of smooth, and flat shading here. And the selected edges are the ones you want to flat shade, while keeping everything else smooth.

However, if you do alot of hard surface modelling, similar to the image above, it’d be very tedious, and time consuming to do all that labour manually. Thats when you turn to auto smooth. It does exactly that, it sets some edges to flat, based on the angle.

It is literally exactly the same as setting edges to smooth/flat yourself, only it does the blunt of the work automatically.

I would never recommend using auto smooth for any organic modelling, like you’re doing now.

Side note, for fur, look into using particle systems to distribute hair cards, i think you will come across this easily by just doing generic research on the subject, as it is extremely common.

Hi Final, thanks for helping!
I’ve done a ton of research before I started this project (it was my most expensive commission, so I took the research stuff seriously), but I had reason for my way of work.

My workflow was this way because I was trying out some new techniques and because this was a game asset and a commission.
Firstly, the Gaming Engine I’m using is very limited, so I had to keep my Triangle count low, and the engine doesn’t support Blender’s particle system so I wouldn’t have been able to import hair particles into the game. Meaning I had to keep things as hair cards instead of a hair particle like most wolf models you see.
Secondly, my commissioner wanted the asset to be one whole mesh, while also having it rigged. Meaning this whole model in total; including the body, face, fur, and mouth, had to be under 10k.
With all these limitations and factors in mind, I had to do my best to stay within tri limits while providing what my client wanted, hence why my workflow was this way.

I had to keep the whole model under 10k tris, while making sure some areas had enough triangles so that the mesh didn’t bend weirdly at the joints, especially since the model has facial muscles.


The joint areas ate up at my tri limit for smoother bending and folding, especially the face which took the most triangles, so I wasn’t able to add too many hair cards like what you suggested below.
The model would’ve gone far above 10k tris had I added a ton of hair cards.


My main inspiration for the hair cards was from this wolf model by plantworld3d,


where the fur flabs were extruded from the main model, keeping the whole model as one mesh.


So I tried to make my wolf similar, and it turned out wonderfully, but being able to see where I extruded from with Auto Smooth on kept bothering me.


I actually didn’t need the Auto Smooth for this model, but I asked the question anyway as I was wondering how I could improve with my next model since I learned about hair cards and opacity maps in the making of my wolf model.


Anyways, thanks again for the help. I highly appreciated the fact you made a video on how I could fix my issue, as a visual learner I couldn’t have asked for a better demonstration.
As I might not be able to fix my workflow much because of the Game Engine I’m using, this will help me a lot the next time I’m forced by a client to have smooth hair cards while also having some sharp edges on the same mesh!
Thank you!