Auto smooth, subsurface and its render in Cycles

Hello everyone.
I made a simple model in Blender 2.93, enabled Auto smooth and gave it a subsurf of 2 and it rendered like this

Right, I thougt, subsurf is too much, lets remove it, infact, lets remove auto smooth as well, but I am still getting the sme “molten” effect.
Could you advise me or suggest a tut on how to go about it. I need literally clean cut through the sphere. Thank you.

Look like an extra face connecting to God knows where

For future helps post under support section

Topic moved to #support:modeling

Thank you for your advise, but I have to confess that the solution was in enabled render view of one of the underlying objects.